Aide:ÉditeurVisuel

Une page de Wikipédia, l'encyclopédie libre.
Aller à : navigation, rechercher
Raccourci : Aide:EV
ÉditeurVisuel
Cette page ne concerne que l'ÉditeurVisuel
Modifier une page de Wikipédia est faisable par n’importe qui, pour y apporter du contenu, corriger une faute, améliorer le style... Cette page présente l’Éditeur Visuel permettant de faire de telles modifications.
Important : pour vos essais, ne modifiez pas cette page ! Le Bac à sable est fait pour cela.


Ouvrir l’ÉditeurVisuel

Pour modifier une page avec l’ÉditeurVisuel, cliquez sur l’onglet « Modifier » en haut de la page.

Le chargement de la page en mode édition peut prendre plusieurs secondes, voire plus si la page est très longue.

Cliquer sur l’onglet « Modifier le code » ouvrira l’éditeur classique de wikicode.

VisualEditor - Edit tab - fr.png

Vous pouvez également ouvrir l’ÉditeurVisuel en cliquant sur le lien « modifier » de chaque section.

VisualEditor - Section edit links - fr.png

Pour commencer : la barre d’outils de l’ÉditeurVisuel

Copie d’écran de la barre d’outils de l’Éditeur Visuel.

La barre d’outils de l’ÉditeurVisuel apparaît en haut de l'écran lorsque vous commencez à modifier la page.

Cliquer sur le chevron VisualEditor - Icon - Expand.svg ouvrira un menu déroulant. Le chevron est toujours situé à droite du nom du menu déroulant correspondant.
La barre d'outils contient quelques icônes familières :


VisualEditor - Toolbar - Undo-redo.png

Annuler et Rétablir les changements que vous avez effectués.


VisualEditor Toolbar Headings-fr.png

Le menu déroulant Titres de sections : vous permet de changer le format du texte. Pour changer le style d’un paragraphe, placez le curseur dans le paragraphe et sélectionnez un élément dans ce menu (vous n’avez pas besoin de surligner de texte). Les titres de section sont intitulés « Titre de section » et les sous-sections sont « Titre 2 », « Titre 3 » et ainsi de suite. Le format normal pour le texte est « Paragraphe ».


VisualEditor Toolbar Formatting-fr.png

Mise en forme : Cliquer sur le bouton « A » ouvre un sous-menu. Vous devez avoir d’abord sélectionné (en surlignant) du texte pour qu’un formatage soit appliqué.

  • L’icône « Gras » (G) met en gras le texte sélectionné.
  • L’icône « Italique » (I) met en italique le texte sélectionné.
  • L’icône « Exposant » (x2) rend le texte sélectionné plus petit que le reste du texte et légèrement surélevé.
  • L’icône « Indice » (x2) rend le texte sélectionné plus petit que le reste du texte et légèrement abaissé.
  • L’icône « Barré » (S) barre le texte sélectionné.
  • L’icône « Code informatique » (deux accolades : {}) modifie la police de caractères du texte sélectionné en police à chasse fixe, ce qui le distingue du reste du texte en police proportionnelle.
  • L’icône « Souligné » (U) ajoute une ligne sous le texte sélectionné.
  • L’icône « Langue » (Aあ) vous permet de marquer la langue (par exemple le japonais) et la direction (par exemple de droite à gauche) du texte sélectionné.
  • La dernière icône (VisualEditor MediaWiki theme clear icon bitmap.png), appelée « Effacer le style » retire tout le formatage du texte sélectionné, y compris les liens.

VisualEditor - Toolbar - Linking.png

Lien hypertexte : la chaîne est l’outil de liens hypertextes. Cliquer dessus (généralement après avoir sélectionné du texte) ouvre la boîte de dialogue des liens.


Citer1.PNG

Citer2.PNG

Citer3.PNG

Citer4.PNG

Menu Citer : le menu « Citer » est utilisé pour ajouter des références dans le texte (sous la forme [1]).

Il y a 3 onglets :

Automatique
Insertion automatique : pour citer un site web, un ouvrage ou un article.
Manuel
Insertion manuelle: pour citer un site web, un ouvrage, un article, ou la forme de base (parfois appelé « autre référence »). Il faudra remplir manuellement les champs. Cet onglet permet de mettre une référence dans le cas où l'insertion automatique ne fonctionnerait pas.
Réutilisation
Réutilisation d'une référence (dans le cas où la référence se trouve déjà dans l'article)

Pour insérer une nouvelle référence dans un article, il y a 2 choix : l'insertion automatique (plus facile) ou l'insertion manuelle.


VisualEditor Toolbar Lists and indentation-fr.png

Listes et indentation : les deux premières icônes vous permettent d’insérer respectivement une « Liste à puces » et une « Liste numérotée ». Les deux icônes suivantes servent à augmenter ou réduire d’un cran le niveau d’indentation du texte.


VisualEditor Insert Menu-fr.png

Insérer : le menu déroulant « Insérer » permet d’insérer plusieurs éléments.

  • L’icône « Média » (une image de montagnes) ouvre la fenêtre des fichiers multimédias.
  • L’icône « Modèle » (une pièce de puzzle) vous permet de modifier des modèles.
  • L’icône « Commentaire » (un phylactère) vous permet d’insérer des commentaires qui ne sont pas visibles pour les lecteurs. Ces commentaires ne peuvent être vus que lors de l’édition de l’article et sont alors indiqués par une icône de point d’exclamation.
  • L’icône « Tableau » (un tableau) vous permet d’insérer un tableau. Vous pourrez après la création ajouter une légende, fusionner des cellules ou supprimer le tableau en utilisant le bouton Tableau à droite du bouton Insérer.
  • L’icône « Galerie » (un ensemble de photos) vous permet d’insérer une galerie sur la page.
  • L’icône « Formule » (Σ) ouvre l’assistant d’insertion de formules mathématiques.
  • L’icône « Liste des références » (trois livres) ouvre une boîte de dialogue où vous pouvez spécifier l’endroit où les références seront affichées pour le lecteur. Vous n’aurez normalement besoin d’utiliser cette boîte de dialogue qu'une seule fois par page.

VisualEditor Toolbar SpecialCharacters-fr.png

Insertion de caractères spéciaux : lorsqu’on clique sur l’icône « Caractères spéciaux » (Ω), une boîte de dialogue apparaît, affichant plusieurs caractères spéciaux. En cliquant sur un caractère donné, vous le placez dans le texte. Il s’agit de certains symboles standards, de lettres accentuées et de symboles mathématiques.


Option page.PNG

Le menu « Options de page » VisualEditor - Icon - Menu.svg est à gauche du bouton « Enregistrer la page ». Ce menu comprend des options pour ajuster les paramètres de la page, tels qu’indiquer si la page est une redirection ou comment elle doit être indexée, ainsi que pour ajouter, modifier et supprimer des catégories ou pour voir, en utilisant l’item « Langue », la liste des articles sur le même sujet dans d’autres langues. Vous pouvez aussi basculer (dans ce sens seulement) de l’Éditeur Visuel vers l’éditeur classique de wikicode sans perdre votre travail d’édition.

Enregistrer ses modifications

Quand vous avez terminé de modifier la page, cliquez sur le bouton bleu intitulé « Enregistrer la page » dans la barre d’outils. Si vous n’avez pas fait de modification, le bouton sera désactivé (grisé). Pour annuler tous vos changements, fermez simplement la fenêtre du navigateur.

VisualEditor cancel save-fr.png

Cliquer sur le bouton bleu « Enregistrer la page » ouvre une boîte de dialogue. Vous pouvez y entrer un bref résumé de vos modifications, marquer votre modification comme mineure et ajouter la page à votre liste de suivi. Le champ pour le résumé est l’équivalent du champ
Afin que les participants à cette page puissent rapidement comprendre vos modifications, merci de les résumer ci-dessous (par exemple, ajout d'un paragraphe, mise en forme…) :
dans l’éditeur de wikicode.

Vous pouvez vérifier vos modifications en utilisant le bouton « Relire vos modifications » pour être sûr qu’elles sont bien comme prévu avant d’enregistrer vos modifications, comme le bouton « Voir mes modifications » dans l’éditeur de wikicode.

Le bouton « Annuler » vous renvoie vers la page que vous modifiez. Vous pouvez sauvegarder vos modifications plus tard.

VisualEditor save dialog-fr.png

Modifier des liens

VisualEditor - Toolbar - Linking.png

Les liens peuvent être ajoutés grâce à l’icône « Lien » (des maillons de chaîne) dans la barre d’outils ou en utilisant le raccourci clavier Ctrl + K (ou Command + K sur un Mac).

Si vous sélectionnez (surlignez) du texte puis que vous cliquez sur le bouton « Lien », un lien sera ajouté en utilisant ce texte. Pour les liens d’un seul mot, il suffit de le faire quand le curseur est sur ce mot.


VisualEditor - Link editing inline 2 - fr.png

Quand vous utilisez l’icône ou le raccourci clavier, une boîte de dialogue s’affiche afin que vous entriez le lien.

L’Éditeur Visuel vous aidera pour les liens internes en recherchant des titres probables lorsque vous commencez à taper.

Le texte affiché correspond au texte surligné avant de cliquer sur l’icône « Lien » (maillons de chaîne).


VisualEditor - Link editing inline box-fr.png

Une fois que vous avez entré ou sélectionné le lien, vous allez compléter la création du lien en pressant la touche Entrée, en cliquant le bouton « Terminé » ou simplement en cliquant hors du cadre. Votre lien apparaîtra immédiatement sur la page dans l’Éditeur Visuel, mais il ne sera pas sauvegardé tant que vous n’aurez pas enregistré la page complète.


VisualEditor - External link - fr.png

Pour lier une page d’un site internet extérieur à Wikipédia, le processus est identique : entrez simplement l’URL dans le champ et le lien sera ajouté en tant que « <visualeditor-linkinspector-button-external-link> ».


VisualEditor - Link editing inline - fr.png

Pour modifier ou supprimer un lien existant, cliquez dans le texte du lien, puis cliquez sur l’icône « Lien » qui apparaît juste à côté. La boîte de dialogue de modification va apparaître. (Vous pouvez également ouvrir la boîte de dialogue en utilisant le raccourci clavier Ctrl + K en étant sur le lien.)

Dans la boîte de dialogue, vous pouvez ensuite modifier la cible du lien. Vous pouvez aussi le supprimer entièrement en cliquant sur le bouton « Supprimer » dans le coin inférieur gauche de la boîte de dialogue. Vous pouvez aussi ouvrir la cible du lien dans une autre fenêtre en cliquant le bouton « Ouvrir ». (Vous voudrez probablement réaliser cela pour vérifier qu'un lien externe est valide.)

Modifier des références

Modifier une référence existante

VisualEditor - Editing references 1 - fr.png

Pour modifier une référence existante, cliquez dessus à l’endroit où elle apparaît dans le texte (généralement un nombre). Vous verrez soit une icône « Autre référence » (marque-page) ou une icône (et un nom) pour le modèle qui a été utilisé pour créer cette référence. Cliquer sur cette icône va ouvrir un mini-éditeur où vous pouvez modifier la référence.

La mini-boîte de dialogue apparaîtra s'il s'agit de l’icône « Autre référence ».

La mini-boîte d'édition apparaîtra s'il s'agit de l’icône « Article », « Site web » ou « Ouvrage ».


VisualEditor - Editing references 6 - fr.png

Si ce qui apparaît est l’icône « Autre référence », cliquer dessus ouvre un mini-éditeur dans laquelle vous pouvez modifier le contenu de la référence.

Une même référence peut contenir plusieurs modèles.

De nombreux wikis utilisent des modèles pour mettre en forme les références. Si un modèle est utilisé dans votre référence, tout le texte contenu dans le modèle sera surligné lorsque vous cliquerez sur les informations de la référence.

Si un modèle a été utilisé et que vous cliquez sur le texte de ce modèle, l’icône « Modèle » (une pièce de puzzle) apparaîtra. Cliquez dessus pour changer le contenu du modèle dans le mini-éditeur.


VisualEditor - Editing References - Articlemai.png

Si après avoir cliqué sur une référence apparaît une icône pour un modèle standard de référence au lieu de l’icône « Autre référence » (un marque-page), cliquer sur cette icône ouvrira directement le mini-éditeur de modèle.


VisualEditor - Editing references 5 - fr.png

Dans le mini-éditeur de modèle, vous pouvez ajouter ou enlever des informations ou modifier le contenu. Seuls les champs (les paramètres du modèle) ayant du contenu sont normalement montrés initialement. Pour ajouter des champs, cliquez sur « Ajouter plus d’informations » en bas du mini-éditeur.


VisualEditor - Apply changes - fr.png

Cliquez sur « Appliquer les modifications » quand vous avez terminé.

Insérer une nouvelle référence

Citer1.PNG

Pour ajouter une référence en utilisant le menu « Citer », placez votre curseur là où vous souhaitez insérer la référence dans le texte, cliquez ensuite sur "Citer".

Menu Citer : le menu « Citer » est utilisé pour ajouter des références dans le texte (sous la forme [1]).

Il y a 3 onglets : Automatique, Manuel, Réutilisation.

Pour insérer une nouvelle référence dans un article, il y a 2 choix : l'insertion automatique (plus facile) ou l'insertion manuelle.

L'onglet Réutilisation sert uniquement dans le cas où la référence se trouve déjà dans l'article

1- Insertion automatique de la référence (le plus simple)

Citer2.PNG

Insertion automatique de la référence : pour citer un site web, un ouvrage ou un article; en utilisant l'onglet Automatique du menu «Citer ».

Pour ajouter une référence en utilisant le menu « Citer », placez votre curseur là où vous souhaitez insérer la référence dans le texte, cliquez ensuite sur "Citer".

Si vous souhaitez une note détaillée, choisissez Autre référence. Ainsi, si vous souhaitez utiliser un Ouvrage comme référence, mais en précisant une citation de l'ouvrage, il vous faudra choisir Autre référence (et dans l'éditeur de référence, ajouter les modèles Ouvrage et Citation).

2- Insertion manuelle de la référence

Pour citer des sites web, articles, ouvrages
Citer3.PNG

Insertion manuelle de la référence: pour citer un site web, un ouvrage, un article, ou la forme de base (parfois appelé « autre référence ») ; en utilisant l'onglet Manuel du menu « Citer».

Il faudra remplir manuellement les champs. Cet onglet permet de mettre une référence dans le cas où l'insertion automatique ne fonctionnerait pas.

(note:La forme de base est une forme qui peut contenir plusieurs modèles)


VisualEditor - Editing references - Cite book required fields.png

Cliquer sur une icône de modèle comme « Ouvrage » vous amène dans le mini-éditeur de modèle pour celui-ci. Les champs obligatoires sont marqués avec un astérisque, les plus utilisés sont affichés par défaut, mais peuvent être laissés vides.


VisualEditor - Editing references - Add parameter.png

Pour ajouter d'autres paramètres, descendez dans l'éditeur de modèles miniature et cliquez sur l'option « Ajouter plus d’informations ».

Cliquez sur « Insérer » lorsque vous avez terminé.

Pour citer en utilisant la Forme de base
VisualEditor - Editing references 20 - fr.png

Dans l’éditeur de référence, vous pouvez modifier ou mettre en forme la note.

Vous pouvez faire appartenir la référence à un groupe, mais en général cette option est laissée vide. (Cette fonctionnalité permet ensuite d’afficher un groupe particulier de références avec l’outil « Liste des références ».)

Si vous souhaitez une note détaillée, choisissez Forme de base. Ainsi, si vous souhaitez utiliser un Ouvrage comme référence, mais en précisant une citation de l'ouvrage, il vous faudra choisir Autre référence (et dans l'éditeur de référence, ajouter les modèles Ouvrage et Citation).


VisualEditor Template Insert Menu-fr.png

Dans l’éditeur de référence, si vous souhaitez inclure un modèle dans la référence, cliquez sur l’icône « Modèle » (une pièce de puzzle) dans la barre d’outils déroulante « Plus » de l’éditeur de références.


VisualEditor - Editing references 9 - fr.png

Ensuite, cherchez le modèle que vous voulez insérer, ajoutez-le et modifiez-le de la même façon que pour n'importe quel autre modèle (voir la section Modifier des modèles ci-dessous si vous avez besoin de plus d'information sur les modèles).

Après avoir fini de modifier votre nouveau modèle, cliquez sur « Appliquer les modifications » pour retourner à l’éditeur de référence, puis de nouveau sur « Appliquer les modifications » pour revenir à la page que vous modifiez.


VisualEditor Reference List Insert Menu-fr.png

S’il n’y a pas encore de liste de références sur la page (par exemple, si vous êtes en train d’ajouter la première référence), vous devez l’ajouter afin d’afficher le texte de votre référence.

Placez votre curseur là où vous souhaitez afficher la liste de références (habituellement en bas de page), ouvrez le menu « Insérer » et cliquez sur l’icône « Liste des références » (trois livres) pour l’ajouter.


VisualEditor - Editing references 11 - fr.png

Si vous utilisez plusieurs groupes de références, ce qui est assez rare, vous pouvez les indiquer dans cette boîte de dialogue. Seules les références appartenant à ce groupe seront affichées ici.

La dernière étape consiste à cliquer sur « Insérer » dans la boîte de dialogue de la liste de références.

Réutiliser une référence existante

Citer1.PNG

Citer4.PNG

Réutiliser une référence avec l'onglet Réutilisation du menu « Citer » :

(quelle que soit la référence : ouvrage, site web, article ou forme de base)

Dans le cas où la référence se trouve déjà dans l'article, vous pouvez réutiliser la référence déjà existante.

Pour réutiliser une référence existante, placez votre curseur là où vous souhaitez l’insérer dans le texte puis cliquez sur l’icône « Référence déjà existante » du menu « Citer ».


VisualEditor - Editing references 18 - fr.png

Dans la boîte de dialogue « Référence », cherchez la référence que vous souhaitez utiliser dans la liste et sélectionnez-la. S’il y a de nombreuses références, vous pouvez utiliser le champ de recherche (marqué « Chercher dans les références actuelles ») pour n’afficher que les références qui incluent un texte donné.

Modifier des images et d’autres fichiers multimédias

Modifier des images

Pour ajouter une nouvelle image (ou un autre fichier multimédia) à la page, cliquez sur l’icône « Média » (une image de montagnes) dans le menu déroulant « Plus ». L’image sera ajoutée au niveau de votre curseur.

VisualEditor Media Insert Menu-fr.png

Cliquer sur l’icône « Média » ouvre une boîte de dialogue qui vous permet de chercher des fichiers multimédias en relation avec la page que vous éditez, simultanément dans le Wiki de votre langue et sur Wikimedia Commons.

Vous pouvez chercher d’autres fichiers en changeant le texte situé dans la barre de recherche de cette boîte de dialogue.

Cliquez sur une vignette pour sélectionner un fichier.

Cela place l'image dans la page que vous éditez.

VisualEditor - Media editing 2 - fr.png

Une fois que l'image sélectionnée est insérée dans la page, une autre boîte de dialogue s'ouvre. Elle vous permet d'ajouter ou de modifier une légende, qui peut également être mise en forme et contenir des liens.

VisualEditor - Media editing 6 - fr.png

La boîte de dialogue média vous permet aussi d'ajouter une légende texte alternative à la photo pour les utilisateurs utilisant des lecteurs d'écran.

Media editing 7.png

Vous pouvez aussi configurer divers paramètres de l'image dans la fenêtre « Paramètres avancés », notamment l'alignement, la mise en page (« type ») et la taille de l'image.

VisualEditor - Media editing 8.png

Quand vous avez terminé, cliquez sur « Appliquer les modifications » pour fermer la boîte de dialogue et retourner à l’édition de la page.

VisualEditor - Apply changes - fr.png

Pour une image existante, vous pouvez ajouter ou modifier une légende ou d'autres paramètres en la sélectionnant, puis en cliquant sur l'icône « Média » qui apparaît sous l'image.

Vous pouvez retailler une image existante en cliquant dessus, puis en tirant l'icône d'ajustement de taille (la flèche à deux têtes en bas à gauche de l'image).

Vous pouvez aussi glisser-déposer une image à un autre endroit de la page.

VisualEditor - Media editing 3 - fr.png

Modifier des galeries de médias

Pour modifier une galerie existante dans l’Éditeur Visuel, cliquez sur celle-ci, puis cliquez sur l’icône « Galerie » (un groupe de photos) vers le bas de la galerie. Apparaît alors l’éditeur de galerie avec la liste complète des images incluses dans cette galerie.

VisualEditor - Gallery2.png

L’éditeur de galerie est pour le moment une simple boîte de dialogue vous permettant d’éditer les galeries existantes en utilisant le balisage wikicode. Pour ajouter une nouvelle image à une galerie existante, taper le nom du fichier suivi par une barre verticale (|) et la légende de cette image. Vous devez placer chaque image de la galerie sur sa propre ligne. Vous pouvez aussi modifier cette liste pour supprimer ou ré-arranger les image ou pour modifier les légendes.

Lorsque vous cliquez sur le bouton « Terminé », vous quittez l’éditeur de galerie. Vous devriez ensuite voir les modifications effectuées sur la galerie et le résultat comme il apparaîtra aux autres lecteurs.

Souvenez-vous que quitter l'éditeur de galerie ne sauvegarde pas vos modifications. Comme pour les autres autres modifications réalisées avec l'Éditeur Visuel, vous devez sauvegarder la page entière pour que tout votre travail soit sauvegardé.

VisualEditor - Gallery3.png

Modifier des modèles

Pour ajouter un nouveau modèle à la page, placez votre curseur là où vous souhaitez insérer le modèle et cliquez sur l’icône « Modèle » (pièce de puzzle) dans le menu « Insérer ».

VisualEditor Template Insert Menu-fr.png

Tapez le nom du modèle que vous souhaitez insérer. Lorsque vous le voyez dans la liste, sélectionnez-le. Cliquez ensuite sur « Ajouter le modèle ».

VisualEditor - Template editing 4 - fr.png

Vous pouvez également modifier des modèles qui sont déjà sur la page en les sélectionnant (ils deviennent bleus), puis en cliquant l’icône « Modèle » (une pièce de puzzle) qui apparaît à côté.

VisualEditor - Template editing 1 - fr.png

Ajouter un nouveau modèle ou en ouvrir un existant affiche la boîte de dialogue de « Insertion d’un modèle ». Si le modèle a été mis à jour avec des métadonnées TemplateData, alors la boîte affichera une liste des paramètres disponibles; sinon un lien vers la documentation du modèle sera affiché à la place.

VisualEditor - Template editing 2 - fr.png

Pour un modèle existant, vous modifiez les paramètres déjà présents et vous pouvez en ajouter d’autres en cliquant sur « Ajouter plus d’informations » tout en bas de la boîte de dialogue.
VisualEditor - Template editing 3 - fr.png

Quand un modèle transclus embarque d’autres transclusions de modèles, ces sous-modèles apparaissent parmi ses paramètres. Ils peuvent être modifiés ou supprimés en cliquant sur leur nom.

Pour ajouter un nouveau sous-modèle, insérez-le comme lorsque vous insérez un nouveau paramètre. Il vous faudra peut-être vérifier que le modèle principal accepte les sous-modèles.

VisualEditor - Template editing 5 - fr.png

Quand vous avez terminé, cliquez sur « Appliquer les modifications » pour fermer la boîte de dialogue et retourner à l’édition de la page.

VisualEditor - Apply changes - fr.png

Substituer des modèles

Quand un modèle doit être substitué, entrez subst: (avec le deux-points) devant le nom du modèle.

La complétion automatique ne fonctionne pas avec subst: ; si vous souhaitez bénéficier de la complétion automatique, ajoutez subst: devant le modèle uniquement après avoir trouvé celui que vous cherchiez.

Ensuite, cliquez sur le bouton vert intitulé « Ajouter le modèle ».

VisualEditor - Template editing 7 - fr.png

Ajoutez les paramètres comme pour un modèle classique et cliquez sur « Appliquer les modifications ».

VisualEditor - Template editing 6 - fr.png

Vous ne verrez pas le modèle s’afficher sur la page durant cette phase initiale.

VisualEditor - Template editing 8 - fr.png

Modifier des tableaux

Insérer tableau.PNG

Vous pouvez utiliser l’Éditeur Visuel pour insérer et modifier des tableaux. C’est une fonctionnalité récente susceptible d’évoluer. Pour insérer un tableau, cliquez sur le menu déroulant « Insérer » puis « Tableau ». Vous pouvez également importer des tableaux en faisant un glisser-déposer d’un fichier de valeurs séparées par des virgules (.csv) depuis votre ordinateur vers la fenêtre d’édition.


VisualEditor - fr - insérer colonne.png

Vous pouvez ajouter et supprimer des colonnes et des lignes.


VisualEditor-logo.svg

Double-cliquez dans une cellule pour ajouter du contenu ou le modifier.

Modifier des catégories

VisualEditor - Toolbar - Page settings - fr.png

Pour modifier les catégories, dans le menu « Options de page » VisualEditor - Icon - Menu.svg, cliquez sur le bouton « Catégories ».


VisualEditor - Category editing 1 - fr.png

Le bouton « Catégories » ouvre une boîte de dialogue qui liste les catégories existantes et vous permet d’en ajouter d’autres.

Vous pouvez définir ou changer la clé de tri par défaut, qui est utilisée pour déterminer l'ordre d'apparition de la page dans les listes de pages par catégorie.

Par exemple, la clé de tri pour l'article « Claude Monet » est « Monet, Claude », donc dans la catégorie « Peintre impressionniste français », l'article est listé sous la lettre « M », et non la lettre « C ».


VisualEditor - Category editing 3-fr.png

Pour ajouter une catégorie à une page, tapez le nom de la catégorie dans le champ « Ajouter une catégorie ». L’Éditeur Visuel va afficher dynamiquement les catégories correspondant à ce que vous entrez. Vous pouvez soit sélectionner une catégorie existante soit vous pouvez ajouter une catégorie qui n’a pas encore de page (la nouvelle catégorie apparaîtra rouge jusqu’à ce que la page de la catégorie soit créée).


VisualEditor - Category editing 2 - fr.png

Pour retirer une catégorie existante, cliquez dessus et cliquez sur l’icône « Supprimer » (une poubelle) dans la boîte de dialogue qui apparaît.

Sélectionner une catégorie vous permet aussi de définir une clé de tri pour celle-ci. Cette clé remplace la clé de tri par défaut.


VisualEditor - Apply changes - fr.png

Cliquez sur « Appliquer les modifications » quand vous avez terminé de modifier les catégories pour retourner à l’édition de la page.

Modifier les paramètres de la page

VisualEditor - Page Settings menu.png

Pour changer les paramètres d’une page, ouvrez le menu « Options de page » dans la barre d’outils et cliquez sur le bouton « Paramètres de la page ».


VisualEditor Page Settings-fr.png

Le bouton « Paramètres de la page » ouvre une boîte de dialogue contenant plusieurs options.


VisualEditor Page Settings Redirects-fr.png

Vous pouvez transformer la page que vous éditez en une redirection vers une autre page en cochant la case « Rediriger cette page vers » et en tapant le nom de la page vers laquelle vous voulez que les lecteurs soient redirigés.

Tout en bas se trouve une option pour désactiver la mise à jour de cette redirection en cas de renommage de la page cible. Ceci est très rarement utilisé.


VisualEditor Page Settings TOC-fr.png

Vous pouvez activer ou désactiver l'affichage d'une table des matières en sélectionnant l'un de ces trois boutons. L'option par défaut est « Si nécessaire », qui affiche la table des matières pour trois titres ou plus.


VisualEditor - Page Settings Edit Links.png

Vous pouvez cacher les liens d'édition à coté de chaque section en cochant cette case.


VisualEditor Apply Changes-fr.png

Cliquez sur « Appliquer les modifications » lorsque vous avez terminé d’éditer le « Options de page » pour revenir à l’édition de la page.

Modifier des formules mathématiques

Pour ajouter une formule mathématique à l'article, placer le curseur à l'endroit où vous souhaitez insérer la formule puis cliquer sur l'icône Σ « Formule » de l'onglet Insérer de la barre d'outils.

VisualEditor Formula Insert Menu-fr.png

Une fenêtre s'ouvre dans laquelle vous pouvez écrire une formule en syntaxe LaTeX. L'Éditeur Visuel met à jour la formule au fur et à mesure que vous l'écrivez, vous pouvez donc ainsi vous rendre compte immédiatement du rendu. Lorsque la formule vous convient, cliquez sur "Terminé".

VisualEditor formula-fr.png

Pour modifier une formule mathématique déjà présente dans l'article, cliquez sur celle-ci puis cliquez sur l'icône « Σ » qui apparaît. Cela ouvrira la fenêtre des formules qui vous permettra d'effectuer les modifications souhaitées.

VisualEditor - editing existing mathematical formula.png

Modifier des poèmes et d’autres éléments spéciaux

Certains éléments, tels que les poèmes et les partitions de musique, ne peuvent pas encore être modifiés avec l’Éditeur Visuel. En attendant, vous devez modifier le wikicode directement si vous souhaitez les modifier ou en ajouter.

Vous ne pouvez pas ajouter de signature ou de date automatique dans une page avec l’Éditeur Visuel.

Raccourcis clavier

De nombreux contributeurs sont habitués à écrire directement en wikicode, notamment lorsqu’il s’agit d’insérer du texte en gras, en italique ou un lien interne. Des raccourcis clavier permettent d’effectuer ces mêmes actions rapidement sans avoir besoin d’utiliser les boutons de la barre d’outils. Voici les raccourcis habituels dans l’Éditeur Visuel :


Raccourci sur PC Action Symbole Raccourci sur Mac

Ctrl + G Gras VisualEditor - Icon - Bold G.svg Cmd + G

Ctrl + I Italique VisualEditor - Icon - Italic-i.svg Cmd + I

Ctrl + K Insérer un lien VisualEditor - Icon - Link.svg Cmd + K

Ctrl + X Couper Cmd + X

Ctrl + C Copier Cmd + C

Ctrl + V Coller Cmd + V

Ctrl + Z Annuler VisualEditor - Icon - Arched-arrow-rtl.svg Cmd + Z

Ctrl + Maj + Z Refaire VisualEditor - Icon - Arched-arrow-ltr.svg Cmd + Maj + Z

Tab Indenter la liste VisualEditor - Icon - Indent-list-ltr.svg Tab

Maj + Tab Désindenter la liste VisualEditor - Icon - Indent-list-rtl.svg Maj + Tab

Ctrl + * µ (clavier AZERTY)

Ctrl + \ | (clavier QWERTY)

Ctrl + $ £ (clavier QWERTZ)

(3e touche à droite de L)

Supprimer la mise en forme VisualEditor - Icon - Clear.svg Cmd + ` £ (clavier AZERTY)

Cmd + \ | (clavier QWERTY)

Cmd + $ £ (clavier QWERTZ)

(3e touche à droite de L)

Liste complète des interactions avec la souris ou le clavier

Fonctionnalité Action
Déplacer le curseur avec la souris Clic sur la position souhaitée
Déplacer le curseur avec le clavier Touches de direction[1]
Sélectionner un contenu avec la souris Déplacer la souris en maintenant le Clic enfoncé
Sélectionner un contenu avec la souris Double et triple Clic
Sélectionner un contenu avec le clavier Maj + Touches de direction[1]
Sélectionner un mot avec la souris Double clic sur un mot
Sélectionner un bloc ou un paragraphe avec la souris Triple clic sur le bloc ou paragraphe
Ajuster la fin de sélection avec la souris Maj + Clic
Précharger la mise en forme du contenu à insérer depuis le contenu actuel Déplacer le curseur avec un clic de la souris ou avec les touches de direction
Insérer du texte avec le clavier N’importe quelle touche alphanumérique et de ponctuation
Insérer des caractères spéciaux avec le clavier Plusieurs touches alphanumériques avec un éditeur de méthode de saisie
Effacer un caractère ou la sélection courante avec le clavier RetArr et Suppr
Effacer un mot avec le clavier (Option ou Alt) + (RetArr et Suppr)
Effacer toute une ligne avec le clavier (Cmd ou Ctrl) + (RetArr et Suppr)
Annuler la dernière opération avec le clavier (Cmd ou Ctrl) + Z
Refaire la dernière opération annulée avec le clavier (Cmd ou Ctrl) + Maj + Z
Copier la sélection actuelle vers le presse-papier avec le clavier (Cmd ou Ctrl) + C
Couper la sélection actuelle vers le presse-papier avec le clavier (Cmd ou Ctrl) + X
Coller le contenu du presse-papier vers la position du curseur (ou à la place de la sélection actuelle) avec le clavier (Cmd ou Ctrl) + V
Copier la sélection actuelle vers le presse-papier avec un menu Ouvrir le menu contextuel du navigateur (accessible sur PC avec un Clic droit sur la sélection actuelle, ou avec la touche Application), puis sélectionner l’option « Copier » (avec un Clic ou Entrée)
Couper la sélection actuelle vers le presse-papier avec un menu Ouvrir le menu contextuel du navigateur (accessible sur PC avec un Clic droit sur la sélection actuelle, ou avec la touche Application), puis sélectionner l’option « Couper » (avec un Clic ou Entrée)
Coller le contenu du presse-papier vers la position du curseur (ou à la place de la sélection actuelle) avec un menu Ouvrir le menu contextuel du navigateur (accessible sur PC avec un Clic droit à la position d’insertion du curseur ou sur la sélection actuelle, ou avec la touche Application), puis sélectionner l’option « Coller » (avec un Clic ou Entrée)
Sélectionner un objet avec la souris Clic sur l’objet
Inverser le style gras de la sélection actuelle ou pour la mise en forme du texte à insérer à la position du curseur avec la souris Clic sur l’icône « Gras » (G) dans la barre d’outils
Inverser le style italique de la sélection actuelle ou pour la mise en forme du texte à insérer à la position du curseur avec la souris Clic sur l’icône « Italique » (I) dans la barre d’outils
Inverser le style gras de la sélection actuelle ou pour la mise en forme du texte à insérer à la position du curseur avec le clavier (Cmd ou Ctrl) + G
Inverser le style italique de la sélection actuelle ou pour la mise en forme du texte à insérer à la position du curseur avec le clavier (Cmd ou Ctrl) + I
Scinder en deux un bloc ou paragraphe avec le clavier Entrée à la position du point de scission
Fusionner deux blocs ou paragraphes successifs avec le clavier RetArr au début du second bloc ou Suppr à la fin du premier
  1. a et b Touches de direction : Haut, Bas, Gauche, Droite, Début, Fin, PageHaut, PageBas.

Voir aussi