Wikipédia:Atelier graphique/Didacticiels cartographiques/Didacticiel de création de carte avec QGIS/Relief ombré

Une page de Wikipédia, l'encyclopédie libre.
Sauter à la navigation Sauter à la recherche

Ce didacticiel vise à créer un relief ombré.

Au préalable il faut combler les éventuelles lacunes dans les données du relief. Suivre pour cela le didacticiel précédent : Création d'un fond topographique > Combler les données topographiques manquantes (si cela n'a pas déjà été fait).

Une fois qu'on a un fichier de données brutes non lacunaires, on crée dans un premier temps un ombrage non transparent, sur fond blanc, puis on traite l'image ainsi créée pour la rendre transparente là où l'ombrage est inutile (dans les plaines par exemple). Plusieurs méthodes possibles :

Avec Global Mapper (sous Windows)[modifier le code]

Méthode avec Global Mapper (résultat).

1) Faire apparaître le relief ombré sur fond blanc :

  • ouvrir votre raster dans Global Mapper ;
  • (étapes 1 à 6 dans l'image ci-contre) rendre l'échelle colorimétrique toute blanche afin de ne voir que le relief ombré sur fond blanc : pour cela, Tools > Configure > Shader options > New > choisir un élévation (height) = -12000 en blanc et une autre 8849 (ou plus, peu importe) dans une autre couleur foncée. Nommez votre échelle (par exemple Échelle blanche pour wiki, exemple ci-contre), enfin dans Vertical options choisir l'échelle blanche que vous venez de créer ;
  • Vérifier que l'ombrage est bien paramétré, c'est à dire : l'azimuth à 315 degrés[1], l'altitude du soleil à choisir autour de 75°, et diverses données à choisir en fonction du terrain et du résultat souhaité, comme l'exagération verticale). Et vérifier que l'ombrage est permis : Tools > Configuration > Vertical options > cocher Enable hill shading.

2) Copie d'écran : il faut faire apparaître dans la fenêtre les limites de la zone d'intérêt.

  • personnaliser la couleur de l'arrière-plan de la fenêtre de Global Mapper de façon à rendre visibles les limites des données du fichier si celles-ci sont les limites de la future carte (exemple : fond noir dans l'image ci-contre) ;
  • ou bien dessiner 2 points correspondant aux coordonnées des coins haut-gauche et bas-droite de la future carte (bouton 'digitizer tool' > bouton 'create new point' > créer les points dans les angles de l'emprise voulue en vérifiant les coordonnées en bas à droite) ;
  • si besoin, changez ensuite la projection (tools > configuration > projection) ;
  • copier la zone d'intérêt avec précision par copie d'écran. Attention à ne pas déborder, cela se verra tout de suite sur la carte. En revanche la précision de l'emprise de la copie d'écran ne sera bien sûr pas absolue (mais cela ne se verra pas).

Avantage : rendu très correct et très léger. Inconvénient : méthode artisanale à partir d'un logiciel propriétaire.

3) Intégration dans la carte svg:

  • préalablement, pour rendre le relief semi-transparent, traiter la copie d'écran avec The Gimp (voir section dédiée, étape généralement obligatoire quelle que soit la méthode) ;
  • placer l'image du relief traité dans la carte svg (Inkscape) ;
  • redimensionner cette image aux proportions de la carte (dans Inkscape veiller à redimensionner proportionnellement hauteur et largeur).

Avec 3DEM (sous Windows)[modifier le code]

Rendu moyen, un peu long mais très facile d'accès. Oblige à se limiter aux deux seules projections possibles du logiciel : lat/lon et UTM.

  • 3DEM > Color scale > Shaded relief > modifier les valeurs.
  • 3DEM > Operation > Modify color > appliquer une couleur blanche à toutes les courbes de niveau. Il ne doit plus apparaître sur la carte que l'ombrage du relief. (Penser à sauvegarder cette « échelle blanche »).
  • 3DEM > Geo coordinates > Grid off.
  • Vérifier que l'ombrage est bien paramétré, c'est à dire : l'azimuth à 315 degrés, l'altitude du soleil à choisir autour de 75°, et diverses données à choisir en fonction du terrain et du résultat souhaité, comme l'exagération verticale).
  • et enfin 3DEM > File > Save map image.

Puis traiter l'image avec The Gimp (voir section dédiée ci-dessous).

Création avec QGIS[modifier le code]

Cette section est une traduction et une synthèse du didacticiel de Yug en anglais équivalent.

Using the plugin "Raster Terrain Analysis plugin" (best but a bit difficult)(Windows or Linux)[modifier le code]

Section en travaux
Need QGIS 1.8.

According to this recent post and its comments :

> QGIS 1.8 > Raster > Terrain Analysis > Relief (the raster will be relief + shade, unfortunaly colors will be discrete and not smooth)

or

> (better)QGIS 1.8 > Raster > Terrain Analysis > Shaded relief (the raster will be only the shade).

It is necessary to enter a number as a "z factor". "z factor" may be 1 or a big number, like 10000 or 100000, in order to make a better relief. So, you have to try different numbers as "z factor". Unfortunaly, flat zones won't be transparent, but thanks to z-factor flat zones will be almost insignificant, while shades of mountains will be enough appreciable.

Example for SRTM90, for a zone about 100x100km. Choose z=75000, and 315° azimuth / 75° altitude. Name this layer shaded relief, and in the properties of this layer > transparency > choose band 1 and set the global transparency to approx. 60%.

>> Or follow the tutorials n⁰1 and n⁰2

No more need to editing the file with GIMP ! (or maybe only for a less-weight file, png to jpg for example)

If you really want a full transparency in flat zones, you must use The Gimp after any of these methods. See below.

Avec Gdaldem hillshape (meilleur rendu. Uniquement sous Linux et MacOS X?)[modifier le code]

Sous Ubuntu, l'installation de QGIS semble aussi installer Gdaldem hillshape.

Commande ([1]) :

$ cd /my/folder/with/my_GIS_files/inside/
$ gdaldem hillshade input_dem.ext output_hillshade.ext -z 5 -s 111120 -az 315 -alt 60

Pour MacOS X, ouvrir un terminal (Application > Utilitaires > Terminal) et trouver le lien vers la commande gdaldem grâce à locate gdaldem et suivre les indications ci-dessus. Le résultat devrait ressembler à :

$ cd /my/folder/with/my_GIS_files/inside/
$ /Library/Frameworks/GDAL.framework/Versions/1.8/Programs/gdaldem hillshade input_dem.ext output_hillshade.ext -z 5 -s 111120 -az 315 -alt 60

(Attention, les noms de vos fichiers à traiter ne doivent pas comporter d'espace (uniquement des _).

Les options spécifiques suivantes sont disponibles :

-z zFactor:
vertical exaggeration used to pre-multiply the elevations
-s scale:
ratio of vertical units to horizontal. If the horizontal unit of the source DEM is degrees (e.g Lat/Long WGS84 projection), you can use scale=111120 if the vertical units are meters (or scale=370400 if they are in feet)
-az azimuth:
Azimut du soleil, en degrés. 0 pour la lumière venant du haut du raster, 90 si elle vient de l'est, etc. La valeur par défaut, 315, n'a pas à être changée et c'est une valeur souvent rencontrée dans les reliefs ombrés.
-alt altitude:
altitude du soleil, en degrés. 90 si la lumière provient du « dessus » de la carte, 0 pour une lumière rasante à l'horizon.

Le fichier créé est un fichier .tif géoréférencé, que QGIS peut donc reprojeter. À exporter ensuite en svg avec le composeur d'impression, puis exporter le svg en png avec Inkscape, pour traitement avec The Gimp.

Avec l'extension Shaded relief (moins bon rendu)[modifier le code]

Page du forum QGIS : Using QGis Shaded relief plugin (forum question)

Il est très facile de créer un relief ombré à partir de l'extension Shaded relief de QGIS, à partir des SRTM ou d'autre MNT.

Pour installer une extension 
voir la section dédiée.
Utilisation de l'extension Shaded relief 
QGis (1.7) > Ouvrir votre raster > Sélectionner la (les) couches dont vous voulez extraire un relief > Extensions > Shaded relief > Shaded relief > (une fenêtre s'ouvre) > Azimuth : 315⁰ (Nord-Ouest ou coin gauche). Inclination : 60⁰. Vertical exaggeration : 0,000009 (à modifier : cherchez la valeur qui donne un bon rendu — en prenant soin de bien sélectionner, à chaque essai, la bonne couche raster) ; Smoothing : 0. > OK.

But the final Print Composer output quality depends of the size of your output.

L'opération peut être appliquée à une série de raster .tif en sélectionnant le dossier qui les contient.

Répétez l'opération pour exporter trois bitmaps, avec chacun un azimut différent : 315, 275, 355.

Avec Gdal[modifier le code]

QGIS 1.8 > Raster > Analyse > MNT/DEM.

Transparence du relief avec The Gimp[modifier le code]

Tutorial The Gimp - Color to alpha.png
  • Méthode rapide pour créer un relief ombré : dans The Gimp, faire Fichier > Ouvrir en tant que calque et ouvrir votre bitmap 315 créé avec QGIS. Appliquer un mode « multiplier » puis faire comme indiqué dans l'image ci-contre : le relief devrait devenir transparent dans les zones non ombrées. Ajouter en tant que calque un deuxième bitmap 315, afin de renforcer l'éclairage principal, et le traiter avec la même méthode. Ajouter et traiter de la même manière vos bitmaps 275 et 355. Puis Image > Fusionner les calques visibles et Image > Mode > pour cocher Niveaux de gris (et non RGB)(afin d'alléger quelque peu le fichier) et enfin exporter en .png (seul ce format supporte la transparence).

Si couleur vers alpha n'est pas disponible, vérifiez bien que dans Image > mode « RVB » est coché.

Notes et références[modifier le code]

  1. Ce qui simule un éclairage du nord-ouest, conventionnel, qui dans la réalité n'existe pas (dans l'hémisphère nord du moins). L'éclairage naturel de l'hémisphère nord vient du sud, mais il provoque une illusion d'optique qui inverse le relief et donne l'impression que les vallées sont des crêtes. Cette illusion est flagrante sur certaines photos satellites, pour lesquelles l'éclairage est forcément naturel.