Wikipédia:Atelier graphique/Didacticiels cartographiques/Didacticiel pour traduire une carte

Une page de Wikipédia, l'encyclopédie libre.
Aller à : navigation, rechercher

Ce didacticiel explique comment traduire une carte ou un schéma, en réécrivant uniquement le texte sans refaire toute la carte. C'est une opération très simple dans la plupart des cas. Ce didacticiel est assez long parce qu'il explique tout le processus en détail, mais en réalité la traduction d'une carte est très simple.

Ce didacticiel est à la portée de tout wikipédien (niveau 1er flocon de wikicartographie).

Premier cas : votre carte (ou image, photo...) est un bitmap[modifier | modifier le code]

C'est-à-dire que le nom de votre image finit par .jpg, .jpeg, .png, ou .gif (les .bmp ne sont pas acceptés par wikimédia). Notez que de certains de ces fichiers sont disponibles sous format .svg (à voir dans la documentation de votre image sur Commons).

Vérifiez bien sur Commons que vous n'avez pas de carte svg équivalente à traduire, ou qui serait vierge (dans ce dernier cas ajoutez simplement les noms au lieu de les traduire). Elle serait plus facile à traduire.

[Par ailleurs, si votre carte est trop complexe (nombreux noms écrits sur un fond très varié), ou si vous souhaitez une plus grande finesse dans les traits, il peut être plus judicieux de vectoriser la carte : voir Wikipédia:Atelier graphique/Didacticiels cartographiques/Didacticiel pour calquer une carte.]

Vous avez besoin du logiciel libre The Gimp, qui s'installe / se désinstalle rapidement (logiciel non envahissant), et est très simple à utiliser (avec un didacticiel).

Étape 1 : ouvrir votre image avec The Gimp

The Gimp est disponible gratuitement ici. Cliquer sur télécharger, enregistrer le fichier, double-cliquez sur l'icône, puis exécute, next, next, install now, et finish. The Gimp se lance et 2 fenêtres apparaissent.

Faire Fichier>ouvrir... et, dans la nouvelle fenêtre intitulée « ouvrir une image », naviguez et sélectionner votre image. Cliquez sur ouvrir.

Note : vous pourrez toujours faire Édition>Annulez pour revenir en arrière dans votre travail. N'hésitez pas à consulter l'atelier graphique si vous rencontrez des difficultés.

Étape 2 : changer la couleur de premier plan

Deux fenêtres apparaissent. Cliquez sur la flèche de permutation de couleur de premier plan en haut à droite. La couleur de premier plan devient le blanc. C'est avec cette couleur qu'on s'apprête à « peindre » par dessus les noms à traduire.

Tutorial translate a map 2.png

Étape 3 : sélectionner la bonne couleur

En effet, si le fond de carte est d'une autre couleur que blanc, il faut cacher les noms avec cette autre couleur. Ici le fond est vert (on va traduire le nom « Walachia » en « Valachie »). Pour changer la couleur de premier plan : cliquer sur le carré de premier plan, puis sur la pipette dans la fenêtre de modification qui apparaît, puis, avec la pipette, cliquer sur le fond de carte : le carré de premier plan devient vert. Enfin cliquez sur le bouton valider.

Tutorial translate a map 3.png

Étape 4 : peindre par-dessus les mots à traduire :

Avec notre nouvelle couleur de premier plan, on va cacher tous les noms à traduire : sélectionnez une brosse (appuyez sur B) et « peignez » par-dessus les noms (Pour changer de couleur de brosse, refaire comme à l'étape 3).

Note : si le fond de votre carte est très détaillé, avec beaucoup de couleurs, un bon résultat sera forcément plus difficile à obtenir.

Tutorial translate a map 4.png

Étape 5 : sélectionner la couleur de votre futur texte

Quand vous avez terminé d'effacer les noms, cliquez sur les flèches de permutation pour retrouver le noir comme couleur de premier plan, qui va servir comme couleur du texte (mais vous pouvez changer cette couleur avec la pipette si vous le souhaitez, comme expliqué à l'étape 3). Cliquez sur valider.

(Note : il vous sera aussi possible de changer la couleur du texte dans la fenêtre de texte.)

Puis cliquez sur le bouton de texte.

Tutorial translate a map 5.png

Élargissez la fenêtre de texte et écrivez les noms en français.

Cliquez sur fermer en bas de la fenêtre de texte. Vous avez plusieurs possibilités de couleurs et de police dans la fenêtre de droite.

Étape 6 : déplacement et rotation du texte

Vous pouvez déplacer ou faire pivoter votre texte :

Tutorial translate a map 6.png

Fin

Faites Fichier > Enregistrer sous en donnant .png comme extension à votre fichier (pas jpg), puis importez l'image sur Commons, sans oublier de mentionner la source.

Second cas : votre carte (ou image, schéma...) est un svg[modifier | modifier le code]

C'est-à-dire que le nom de votre image finit certainement par .svg. La carte est encore plus simple à traduire. (Notez que de certains svg sont disponibles sous format .png, .gif, .jpg, .jpeg (à voir dans la documentation de votre image sur Commons)).

Tout d'abord, avant d'essayer la méthode ci-dessous, vous pouvez faire traduire automatiquement votre fichier svg par un traducteur automatique de svg.

Pour la méthode non automatique présentée ci-dessous, vous avez besoin d'Inkscape, logiciel libre et gratuit qui s'installe / se désinstalle rapidement (logiciel non envahissant), et très simple à utiliser (avec ce didacticiel).

Étape 1 : ouvrir une image avec Inkscape.

Inkscape est disponible ici (site officiel). Cliquez sur Download now en haut à droite de votre fenêtre, puis enregistrer.

Note : dans Inkscape, vous pourrez toujours revenir en arrière à l'aide des flèches en haut à gauche de votre fenêtre. Par ailleurs, lorsqu'une action n'a pas d'effet, pensez à lire le message d'information d'Inkscape en bas de la fenêtre.

Ouvrez Inkscape. Faites Fichier > ouvrir, naviguez et sélectionnez votre image.

Étape 2 : déverrouiller les calques

Déverrouillez les calques s'ils sont verrouillés, grâce au petit cadenas en bas à gauche (il est très préférable de ne déverrouiller que les calques contenant les mots à traduire ; il s'agit en général des calques intitulés « toponymes » ou « cities names », etc.).

Étape 3 : traduction.

Sélectionner le nom à traduire en cliquant dessus (s'il n'est pas sélectionnable, c'est qu'il est soit 1) dans un calque verrouillé, vérifiez alors le déverrouillage ; soit 2) dans un groupe d'objets : sélectionnez alors le groupe et cliquez sur le bouton à côté du pinceau, intitulé « dégrouper les groupes sélectionnés »)[1]. Appuyez alors sur F8 (ou cliquez sur le bouton de texte dans la colonne de gauche). Le curseur se positionne alors à la fin du mot : effacez le mot et remplacez-le par votre traduction.

Fin

Quand tout est traduit, Fichier > Enregistrez sous, puis importer votre image sur Commons sans oublier de mentionner la source.

Maintenance[modifier | modifier le code]

Maintenance : pour toute erreur, remarque ou modification des étapes des logiciels, merci de contacter Bourrichon ou tout autre valeureux wikigraphiste (ou de modifier vous-même ce didacticiel).

Notes[modifier | modifier le code]

  1. Pour plus de précisions sur cette étape, voir les étapes 1 et 2 de Wikipédia:Atelier graphique/Didacticiels cartographiques/Didacticiel pour modifier la couleur d'un pays