Wikipédia:Atelier graphique/Didacticiels cartographiques/Didacticiel pour calquer une carte

Une page de Wikipédia, l'encyclopédie libre.
Aller à : navigation, rechercher

Ce didacticiel explique comment calquer une carte ou simplement ajouter des traits, des objets, etc. à une carte pré-existante, à partir d'un modèle. C'est un didacticiel accessible à tout wikipédien qui a un peu de temps. Par ailleurs chaque étape peut être utilisée indépendamment des autres (notamment à partir de l'étape 6).

Attention.
Control copyright icon.svg

Veillez à ce que ce ne soit pas une création originale, afin de ne pas violer les droits d'auteurs et de base de données de la carte. La carte doit être sous licence libre ou sous domaine public. Si seul le style de votre modèle est original (par exemple une simple carte de France, dont les frontières sont de notoriété publique), vous pouvez vous en inspirer, mais en changeant le style qui est forcément original. Quelques éléments du style : le cadrage, l'épaisseur et la couleur des traits, la couleur des territoires, la couleur de l'océan, les camaïeux, la légende, la place et la composition de la légende, la police, la couleur de la police, la taille du texte, et même le titre s'il apparaît sur la carte. Tous ces éléments font partie du copyright.

Inkscape.
Inkscape Logo.svg

Vous aurez besoin d'utiliser Inkscape. Inkscape est un logiciel libre et gratuit, très facile à installer / désinstaller (logiciel non envahissant) et à utiliser (avec un didacticiel).

Inkscape est disponible ici (site officiel). Cliquez sur Download now en haut à droite de votre fenêtre, puis enregistrer.

Note : dans Inkscape, vous pourrez toujours revenir en arrière à l'aide des flèches en haut à gauche de votre fenêtre. Par ailleurs, lorsqu'une action n'a pas d'effet, pensez à lire le message d'information d'Inkscape en bas de la fenêtre. N'hésitez pas à consulter l'atelier graphique si vous rencontrez des difficultés.

Étape 0 : trouver une carte de base.

Allez sur Commons pour trouver une carte libre et vectorielle (.svg) qui vous évitera de tout faire à partir de zéro, et vérifiez aussi que la carte que vous voulez faire n'existe pas déjà. Choisissez de préférence une carte qui a la même projection. Pour obtenir des fond de cartes SVG, les catégories SVG maps, Location_maps (2008 standard) et leurs sous-pages sont le meilleur endroit où chercher.

Nous nous proposons de faire une carte des routes maritimes du commerce phénicien en Méditerranée, en fait la traduction de cette carte bitmap :

PhoenicianTrade.png

Nous avons trouvé sur Commons cette carte svg des côtes de la Méditerranée, sur laquelle nous allons tracer le parcours des Phéniciens. Nous n'aurons donc pas à tracer toutes les côtes :

Blank map of South Europe and North Africa.svg

Ouvrez votre carte de base avec Inkscape (si vraiment vous ne trouvez pas de carte de base, mais que vous n'avez que votre carte modèle, ouvrez Inkscape et passez directement à l'étape 3).

Étape 1 : recadrer la carte de base si nécessaire.

Recadrez votre carte à l'aide du didacticiel Wikipédia:Atelier graphique/Didacticiels cartographiques/Didacticiel pour recentrer ou découper une carte ou une image (partie concernant les svg, notamment pour les problèmes de redimensionnement, suppression de l'attribut viewbox).

Étape 2 : placer votre carte de base dans un calque.

Un calque est un « étage » dans Inkscape. Il est plus facile de travailler avec une carte dans un calque et une carte dans un autre calque, avec une mise en transparence.

Si votre carte de base n'est pas déjà dans un calque (elle est alors dans Racine), créez un calque : Calque > Ajouter un calque et appelez-le « carte de base ». Votre carte de base doit être dans ce calque et ne doit pas rester dans Racine : sélectionner toute la carte, et faites Calque > Déplacer la sélection au calque inférieur. Vous avez maintenant votre carte de base dans son calque dédié. Verrouillez ce calque.

1 : couleur du remplissage et du contour de l'objet sélectionné. 2 : niveau d'opacité du calque courant ou de l'objet sélectionné. 3 : œil, fermez-le pour rendre invisible et intouchable le calque courant. 4 : cadenas servant à verrouiller/déverrouiller le calque (=le rendre non modifiable bien que toujours apparent). 5 : liste des calques (seul le calque courant apparaît par défaut). Ici le calque est verrouillé donc entre crochets. 6 : information que donne Inkscape sur le calque ou l'objet sélectionné. 7 : palettes de couleurs utilisées pour remplir rapidement un objet.

Étape 3 : placer votre carte modèle dans un autre calque.

Créez un nouveau calque (Calque > Ajouter un calque) et nommez-le « carte modèle ». Vérifiez que le calque « Carte modèle » est bien le calque courant (sélectionnez le calque, le nom du calque se met en gras) et non verrouillé.

Depuis votre bureau, glissez-déposez votre carte modèle dans le calque « carte modèle ».

Étape 4 : transparence et dimensions du modèle.

Diminuez l'opacité et changez la taille du modèle.

Rendez tout d'abord votre modèle transparent : sélectionnez le modèle, puis diminuez l'opacité à l'aide du curseur en bas à gauche.

Adaptez la taille du modèle en utilisant les flèches de redimensionnement.


Étape 5 : créer un 3ème calque qui sera le calque de vos tracés.

D'abord, sélectionnez le calque du haut, et verrouillez tous les calques, de façon à ne pas déplacer certains objets par mégarde en travaillant.

Créez le nouveau calque (Calque > Ajouter un calque) au-dessus du calque courant (vous pouvez monter ou descendre vos calques avec Calque > monter / descendre le calque). Intitulez votre nouveau calque « Calque des tracés » ou « Frontières » ou « Côtes », selon ce que vous voulez faire, mais ne tracez pas toute votre carte dans le même calque : créez un calque pour les frontières, puis un autre pour les côtes, etc. Créez autant de calques que nécessaire, qui vous permettront d'utiliser Édition > sélectionnez tout si vous voulez épaissir les traits de toutes les côtes à la fois mais pas des frontières, par exemple. En résumé, un calque = un type de trait. Veillez à verrouiller les calques du dessous pour ne pas déplacer des objets involontairement ; éventuellement rendez invisibles les calques surchargés qui vous empêchent de bien voir le modèle (petit œil en bas à gauche).

Créez le calque de vos tracés.

Étape 6 : tracer les traits avec shift+F6 ou F6.

Tracez des traits durs avec Shift+F6.

Shift+F6 est un stylo qui trace des segments de droite. Clic gauche (et relâcher) pour créer un nœud, clic droit pour terminer le tracé (que vous pourrez reprendre à partir du nœud terminal). Les segments de droite sont plus pratiques pour les cartes.

F6 est un crayon pour dessiner des traits à main levée. C'est plus précis mais cela demande plus d'adresse.

Vous ne pouvez rien tracer dans un calque verrouillé.


Étape 7 : manipuler les nœuds.

Faites F2 et sélectionnez un nœuds (ou plusieurs, tout en appuyant sur ctrl). Vous pouvez les déplacer, les supprimer, les rendre doux, en ajouter, etc. grâce à la barre d'outil qui apparaît avec F2 en haut à gauche de la fenêtre. Vous pouvez rendre courbe un segment : sélectionnez deux nœuds et « étirez » le segment avec la petite flèche de F2, qui pour l'occasion se transforme en main.

Sectionner un segment : sélectionner un nœud et briser-le. Ce sont maintenant deux segments combinés qui se touchent. Pour les séparer, faites Chemin > Séparer.

Joindre deux segments : sélectionnez vos deux nœuds terminaux (attention, zoomez afin de ne pas vous tromper de nœud), et joignez-les par un segment ou en fusionnant les deux nœuds, toujours à l'aide des boutons de la barre d'outil de F2.

Étape 8 : écrire les noms.

Ajouter un nom avec F8

Verrouillez vos calques, sélectionnez le calque du haut, créez un nouveau calque intitulé « toponymes » ou « noms », etc, selon ce que vous voulez.

Puis utilisez F8 (ou le bouton de texte) pour écrire un mot.

Changez le style du texte : sélectionnez votre texte (ou vos textes en maintenant la touche ctrl appuyée) et faites shift+ctrl+T (ou bouton T ouvrant la fenêtre de police). Dans la nouvelle fenêtre « Texte et police », choisissez votre style (taille, police, etc.[1]) et cliquez sur Enregistrer comme valeur par défaut (ou simplement sur Apply si vous ne voulez pas que vos choix s'appliquent à vos futurs textes). Suivez les recommandations de l'atelier graphique concernant les couleurs, et téléchargez la palette d'objets (à glisser-déposer dans un nouveau calque).

Étape 9 : faire une rotation d'objet.

Vous pouvez faire pivoter votre texte (nom d'un fleuve par exemple) : sélectionner votre objet puis Objet > Transformer > onglet Rotation (angle négatif pour pivoter dans l'autre sens).

Étape 10 : la légende.

Créez un nouveau calque comme expliqué plus haut. Créez un rectangle avec F4. Changez la taille, la couleur, etc. avec Objet > Remplissage et contour (ou petit pinceau). Choisissez un remplissage blanc et un contour noir. Écrivez votre texte de légende avec F8 (cf. étape 6) en veillant à ce que votre texte soit au-dessus du rectangle blanc (en effet, dans un même calque il peut y avoir plusieurs plans : faire Objet > monter / descendre).

Étape 11 : suppression du modèle.

Déverrouillez tous les calques : Objet > Déverrouiller tout. Sélectionnez le calque contenant le modèle à calquer et faites Calque > Supprimer le calque courant.

Il y aura peut-être une image non incorporée à votre svg : faites Effet > Image > Incorporer toutes les images. Pour tout problème d'affichage ou autre, voir la FAQ SVG.

Faites Enregistrer sous... et choisissez le nom de votre carte, se terminant par -fr si elle est en français (par -en en anglais, etc.) et choisissez l'extension .svg.

Importez votre carte sur Commons sans oublier de mentionner les cartes, palettes, etc. dont vous vous êtes servi.

Résultat[modifier | modifier le code]

Routes commerciales des Phéniciens-fr.svg

Notes et références[modifier | modifier le code]

  1. Le logiciel Wikimedia gère mal certaines polices « exotiques ». En général Arial et Times passent bien.