Wikipédia:Atelier graphique/Didacticiels cartographiques/Didacticiel de création de carte topographique vectorielle

Une page de Wikipédia, l'encyclopédie libre.
Aller à : navigation, rechercher

Le but de ce didacticiel est d'apprendre à créer une carte topographique vectorielle à partir de modèles numériques de terrain (MNT) issus de la Shuttle Radar Topography Mission (SRTM) de la NASA en utilisant les logiciels d'édition SIG 3DEM et GRASS GIS.

Carte topographique vectorielle finalisée

L'intérêt d'utiliser les MNT de la SRTM est de nature diverse : les données sont libres (dans le domaine public), en libre accès sur le site de la NASA, précises (jusqu'à une résolution de 31 m à l'équateur), couvrent pratiquement toutes les terres habitées (80 % des terres émergées) et la source est fiable. À ces avantages s'ajoute le fait qu'il y a très peu de risques de faire des erreurs dans le tracé des niveaux d'altitudes comme cela pouvait être le cas en recopiant le cheminement d'une courbe de niveau à partir d'une carte plus ou moins bien scannée, celui d'être plus simple à réaliser qu'un tracé à main levée, mais surtout aussi parce que les données sont instantanément accessibles à tous, économisant en cela un temps très important de recherche de documents libres pour être copiés, ce qui est d'un grand intérêt au sein des Wikipédia. Il faut aussi noter que la carte est au format vectoriel SVG (sauf l'image des ombres du relief) qui peut donc être affichée à n'importe quelle dimension sans perte de qualité. Pour ceux intéressés par une carte réalisée plus simplement et au format bitmap, ils peuvent consulter le didacticiel de création de carte du relief bitmap.

GRASS GIS ne permet pas de re-projeter une carte à la volée : chaque projet de carte est précisément défini dès sa création (localisation géographique, résolution, projection, etc.) et ne peut plus être modifié par la suite. D'autre part, il n'est pas possible d'importer un MNT dans un projet si les projection ne sont pas les mêmes, ce qui nous oblige à créer d'abord un projet suivant la projection native du MNT puis un second dans la projection qui sera utilisée dans la carte finale.

Le processus pour créer ce type de carte comporte donc de nombreuses étapes mais le cheminement en est assez simple :

  • Fusion des MNT et remplissage des trous[1] dans 3DEM ;
  • Création d'un projet suivant la projection native des MNT et importation de la carte dans GRASS ;
  • Création d'un second projet suivant une projection UTM et re-projection de la carte ;
  • Extraction des niveaux d'altitudes ;
  • Création de la carte vectorielle précise des côtes et des lacs et rivières ;
  • Vectorisation de chaque niveau d'altitude dans Inkscape ;
  • Importation de la carte des côtes ;
  • Redressement / recadrage de la carte ;
  • Colorisation de chaque niveau ;
  • Création et intégration de la carte optimisée des ombres du relief ;
  • Création et intégration de la carte de la bathymétrie ;
  • Finalisation de la carte avec la grille des latitudes et longitudes et des échelles.


Exemple (factice) de carte topographique géologique des îles Malouines

En complément, cette page montre aussi comment modifier la carte créée pour réaliser une carte topographique thématique.

Les outils[modifier | modifier le code]

  • 3DEM (version utilisée : 20.3) : éditeur SIG gratuit et simple d'utilisation avec lequel seront remplis les trous des SRTM ;
Remarques :
  • Ce didacticiel présente la méthode pour créer la carte initiale plus rapidement en utilisant 3DEM qui n'est conçu que pour les plates-formes Microsoft Windows 32 bits. Les contributeurs qui utilisent un autre système d'exploitation pourront monter les fichiers SRTM dans GRASS GIS et remplir les trous grâce à son module r.fillnulls.
  • On pourrait utiliser 3DEM pour créer et extraire directement chaque niveau d'altitude suivant une projection UTM, mais lors de tests ce logiciel a montré qu'il engendrait des erreurs assez importantes dans les altitudes lors de la re-projection ce qui le rend impropre à cette tâche.
  • GRASS GIS site officiel (version utilisée : winGRASS6.3.0RC6) : logiciel SIG libre et puissant utilisé pour éditer les modèles numériques de terrain (MNT) et en extraire les niveaux d'altitudes ainsi que les fichiers SRTM Water Body Data (SWBD) qui sont au format vectoriel shapefile. Ces derniers fichiers contiennent le tracé corrigé des côtes[2], et des lacs et cours d'eau d'une certaine importance qui complèteront la carte ;
  • The GIMP (version utilisée : 2.4.5) : éditeur bitmap qui va permettre de préparer la carte des ombres du relief ;
  • Inkscape (version utilisée : 0.46) : logiciel d'édition vectoriel grâce auquel seront vectorisées les données des MNT et celles des SWBD.

Outils additionnels pour la carte de la bathymétrie[modifier | modifier le code]

  • Demis Mapper[3] (page de téléchargement) : version gratuite d'essai du logiciel permettant d'afficher la carte mondiale de Demis ;
  • Demis Worl Map Data (page de téléchargement – 502 Mo) : carte mondiale présentant les mêmes données que Map Clip ou leur add-on pour NASA World Wind avec possibilité de choisir les couches à afficher.

Sources des données[modifier | modifier le code]

Pour d'autres ressources disponibles, consulter : Ressources cartographiques géoréférencées.
Ce sont des fichiers versés dans le domaine public, compressés au format .zip, qui contiennent les données topographiques numérisées de la région considérée. La zone couverte par les MNT issus de la SRTM s'étend de 56° de latitude Sud à 60° de latitude Nord. Il est nécessaire de les décompresser avant de pouvoir les utiliser dans 3DEM. Il y a trois types de fichiers SRTM :
  • SRTM1 (page de téléchargement) : ce sont les données les plus précises avec une résolution d'une seconde d'arc (31 m à l'équateur) mais qui ne sont disponibles que pour les États-Unis et leurs dépendances. Chaque fichier représente un rectangle d'un degré d'arc de côté référencé suivant les coordonnées du coin inférieur gauche[4].
  • SRTM3 (page de téléchargement) : précision de trois secondes d'arc (93 m à l'équateur) qui couvrent toutes les terres émergées comprises entre les latitudes indiquées plus haut. Type de fichiers et références identiques aux SRTM1. Ce sont ces données qui seront le plus souvent utilisées car couvrant la majorité des besoins au sein de Wikipédia.
  • SRTM30 (page de téléchargement) : précision de 30 secondes d'arc (926 m à l'équateur), adaptés pour les cartes couvrant plusieurs pays ou un continent.
Chaque carte couvre une région de 50° en latitude sur 40° en longitude référencée suivant les coordonnées du coin supérieur gauche. Chacune d'elle est contenue dans un répertoire spécifique qui regroupe un ensemble de 12 fichiers. Seuls 10 d'entre eux nous sont utiles, à l'exception des fichiers *.jpg.zip et *.gif.zip qui ne sont que des images de prévisualisation. Ces 10 fichiers devront tous être téléchargés et décompressés avant d'être utilisés dans 3DEM. Dans le logiciel, sélectionner l'option GTOPO30 Tile puis dans la nouvelle fenêtre représentant la carte du monde, centrer le cadre sur la région d'intérêt et spécifier comme projection Lat/Lon. Naviguer dans l'arborescence et sélectionner le fichier .DEM.
  • NASA SRTM Water Body Data (SWBD) (page de téléchargement) : fichiers complémentaires aux SRTM comportant le tracé précis des côtes ainsi que des lacs et cours d'eau d'une certaine importance ;

Création de la carte à partir des MNT[modifier | modifier le code]

Préparation de la carte dans 3DEM[modifier | modifier le code]

1. Télécharger les fichiers SRTM nécessaires, les décompresser. Pour cet exemple, il faut utiliser les fichiers : S51W062.hgt.zip S52W059.hgt.zip S52W061.hgt.zip S53W059.hgt.zip S53W061.hgt.zip S52W058.hgt.zip S52W060.hgt.zip S52W062.hgt.zip S53W060.hgt.zip S53W062.hgt.zip de la base SRTM3.


Chargement des modèles numériques de terrain
2. Ouvrir 3DEM. Cliquer sur File -> Load Terrain Model (1). Sélectionner l'option SRTM Data (2) puis dans la nouvelle fenêtre l'ensemble des fichiers < .hgt >. Confirmer avec Ouvrir.


Remplissage des pixels vides
3. Le MNT comportant des pixels sans informations[1], il est nécessaire de les remplir. GRASS GIS qui sera utilisé par la suite propose cette opération mais elle semble assez délicate à mener et nécessite beaucoup de temps pour être achevée. Pour des raisons de rapidité nous allons donc utiliser cette fonction dans 3DEM qui effectue un travail rapide et satisfaisant pour nos besoins au sein de Wikipédia sauf dans les cas où les zones sans données sont très grandes. Appuyer sur F7 et sélectionner grâce à la souris l'ensemble de la carte (1). Confirmer avec la touche ENTER. 3DEM remplit ces pixels en interpolant les valeurs des pixels adjacents (2). Si la carte est très grande et que 3DEM met trop de temps pour effectuer les calculs, fermer le logiciel et recommencer en sélectionnant une zone plus petite.


Exporter la carte au format GeoTiff
4. Exporter la carte au format GeoTiff qui est un format Tiff standard mais géo-référencé : File -> Save GeoTiff DEM. Cliquer sur le bouton OK de la boîte d'avertissement qui apparaît et enregistrer le fichier dans le dossier racine des projets de GRASS : C:\GRASS\GIS DataBase. Ceci permettra aussi de n'avoir à importer et traiter qu'une seule carte au sein de GRASS ce qui facilitera les opérations.


Re-projeter la carte
5. Re-projeter la carte en UTM : Operation -> Change Projection -> Convert to UTM projection. Sélectionner l'option WGS84 qui est le système géodésique des SRTM puis cliquer sur OK. Cette opération ne vise qu'à récupérer les informations sur les limites de la carte au format métrique UTM, un peu délicates à trouver, et non d'utiliser la carte suivant cette projection qui engendre des erreurs dans 3DEM comme cela a été indiqué plus haut.


Récupérer les coordonnées UTM de la carte
6. Récupérer les coordonnées UTM de la carte qui serviront lors de la création du projet dans GRASS : Operation -> Show DEM Specs. Dans la fenêtre de dialogue qui s'ouvre, noter la zone UTM de la carte (< 21S > – Sud – dans notre exemple) et les valeurs des limites East et North.
  • Une carte mondiale des zones UTM est disponible sur Commons ;
  • Vous pouvez aussi convertir des coordonnées géographiques en UTM en utilisant un outil en ligne comme celui proposé par Digital Mapping Solutions ;
  • Le cas de notre exemple (les îles Malouines) est particulier car la carte est à cheval entre les fuseaux UTM 20 et 21 Sud. 3DEM dans ce cas précis autorise la re-projection en UTM bien qu'en général ce ne soit pas le cas quand la carte couvre plusieurs zones. Ici cela nous facilite grandement la détermination des limites de la carte qui seront nécessaires lors de la création du projet en UTM dans GRASS.


Redimensionner la carte
7. Appuyer sur F6 et déplacer le curseur pour que la carte ait une taille en pixels équivalente à la carte finale. Confirmer avec OK.


Sauvegarder un aperçu de la carte
8. Sauvegarder un aperçu de cette carte qui servira de référence pour tracer la grille des coordonnées : File -> Save Map Image et sélectionner le format jpeg. Cela fait, fermer 3DEM.


Exemple de la Grèce s'étendant sur plus d'un fuseau UTM
9. Si votre carte couvre plus d'un fuseau UTM et que 3DEM ne peut pas la re-projeter en UTM, rouvrez votre carte en ne sélectionnant que les MNT du fuseau central ou qui contient le plus de données puis procédez à la re-projection. Récupérez les coordonnées UTM de cette portion de carte, notez-les puis fermez 3DEM.
  • Remarque importante concernant les coordonnées UTM : Les coordonnées UTM ne sont pas linéaires d'un fuseau à un autre : les coordonnées de la limite Est d'un fuseau ne correspondent pas à celles de l'Ouest du fuseau adjacent qui se trouve à sa droite car le point de référence de chaque zone est particulier à celle-ci (voir pour plus de détail l'article Transverse Universelle de Mercator). Si la carte couvre plusieurs zones UTM on ne pourra donc pas utiliser directement l'outil de transformation des coordonnées de Digital Mapping Solutions car il donnera celles-ci dans la zone dans laquelle se trouve le point considéré.
  • Une méthode très simple et rapide pour connaître approximativement les coordonnées de la carte complète consiste à additionner (si celle-ci dépasse à l'Est du fuseau principal) à la plus grande valeur ou à soustraire (si elle dépasse à l'Ouest du fuseau principal) à la plus petite valeur la longueur au sol d'un degré d'arc au niveau de l'équateur, ceci pour chaque degré (donc fichier SRTM) qui dépasse.
  • Sachant qu'un mille marin qui a une longueur de 1 852 m correspond sensiblement à la longueur d'une minute d'arc au niveau de l'équateur, un degré au niveau de ce grand cercle aura une longueur proche de 1 852 x 60 = 111 120 m. C'est cette valeur que nous ajouterons ou soustrairons aux coordonnées du morceau de carte ne couvrant qu'un fuseau UTM pour chaque degré qui dépasse.
  • Exemple : supposons que nous aillons une carte s'étendant de 17°E à 26°E (peut importe la latitude), donc 1° dans le fuseau 33, 6° dans le fuseau 34 (toute sa largeur) et 2° dans le fuseau 35.
En ne sélectionnant dans 3DEM que les SRTM du fuseau 34 (qui est notre fuseau principal) et en re-projetant ce morceau de carte en UTM, nous lisons dans Operation -> Show DEM Specs pour les coordonnées East:240120 > et < 759690 >.
La carte complète dépassant d'un degré vers l'Ouest, nous soustrayons 111 120 m à 240120 ce qui donne 129000. À l'Est, la carte dépasse de deux degrés, nous ajoutons donc 2 x 111 120 m =222 240 m à 759690 ce qui donne 981930. Ce sont ces deux valeurs qui seront spécifiées pour les limites Ouest et Est lors de la création du projet de ladite carte en UTM dans GRASS.
La zone pour accueillir la carte dans GRASS sera certainement trop large puisque plus on monte en latitude, plus courte est la longueur au sol d'un degré d'arc, mais cela n'a pas d'importance.


Création du projet Lat/Lon pour la carte dans GRASS GIS[modifier | modifier le code]

Lancer GRASS GIS
10. Lancer GRASS GIS et cliquer sur le bouton Projection values pour créer un nouveau projet dans la projection native de la carte (Lat/Lon).


Créer un nouveau projet Lat/Lon
11. Dans la fenêtre DOS qui s'ouvre, entrer un nom (sans accent ni espace ni caractères spéciaux) pour votre projet (= carte) dans le champ LOCATION: (dans notre exemple Iles_Malouines). Le MAPSET: sera PERMANENT et la DATABASE: le répertoire racine contenant tous les projets (C:\GRASS\GIS DataBase par défaut pour la version 6.3RC6 de GRASS). Appuyer sur la touche ENTER puis sur ESC et à nouveau sur ENTER pour continuer.


Confirmer la création du projet
12. Confirmer la création du projet (location) avec ENTER.


Rassembler les informations nécessaires
13. Diverses informations vont être nécessaires à GRASS pour paramétrer votre projet (projection cartographique, limites géographiques de la carte, etc.). Rassemblez ces données puis taper ENTER.


Projection de la carte
14. Projection de la carte. Pour une carte issue des SRTM comme dans notre exemple, c'est Latitude-Longitude qui est leur projection native. Si vous utilisez ces MNT, taper B puis ENTER et confirmer à nouveau avec ENTER.


Description du sujet de la carte
15. Donner une courte description du sujet de votre carte puis taper ENTER et confirmer avec ENTER.


Spécifier le système géodésique
16. GRASS vous demande à présent si vous voulez spécifier un système géodésique pour votre projet. Si vous utilisez les MNT de la SRTM, appuyez ENTER, entrez wgs84 et appuyez à nouveau sur la touche ENTER.
Note : vous pouvez aussi faire défiler la liste de tous les systèmes disponibles en entrant list puis en appuyant sur la touche ENTER.


Spécifier le paramètre de transformation
17. GRASS vous demande de sélectionner les paramètres de transformation du système géodésique. Entrez list et tapez ENTER. Pour le WGS84, seul semble être disponible l'option < 1 >. Entrez donc ce chiffre et appuyez sur la touche ENTER.


Entrer les coordonnées limites de la carte
18. Entrer les valeurs en degrés des limites Nord (N), Sud (S), Est (E) et Ouest (W) de la zone couverte par votre carte. Tapez ENTER pour changer de champ.
Ci-contre, les champs remplis pour l'exemple des îles Malouines qui s'étendent de 53°S à 50°S et de 062°W à 057°W.


19. GRID RESOLUTION : les deux champs représentent la résolution par pixel souhaitée de la carte. Dans le cas des SRTM3, la résolution native est de 3 secondes d'arc (1 seconde d'arc pour les SRTM1 couvrant les États-Unis). Ces valeurs peuvent être entrées sous forme décimale (0.00XX) ou sexagésimale (0:00:XX) ce qui est le plus pratique dans notre cas. Pour une carte utilisant des MNT de la SRTM3 à leur résolution native, entrez la valeur 00:00:03 (correspondant à 0 deg. 0 min. 03 sec.) pour chacun des champs. Confirmer l'ensemble de vos entrées avec ESC puis ENTER. GRASS récapitule les choix que vous avez fait. Si vous êtres satisfait, appuyer ENTER.
Dans l'exemple de droite ci-dessous on peut confirmer que l'on a spécifié la résolution native des MNT de la SRTM3 : la carte s'étendant sur 5° de large et 3° de haut, sa taille en pixels est bien de 5 x 1 200 sur 3 x 1 200 (1 200px x 1 200px étant la taille native d'un SRTM3[5])
Entrée de la résolution
Récapitulation des informations
Entrée de la résolution Récapitulation des informations


Confirmation de la création du projet
20. GRASS vous confirme qu'il a créé la LOCATION (Iles_Malouines dans notre exemple). Appuyer sur ENTER qui vous ramène à l'état initial de la fenêtre DOS. Appuyer sur ESC puis ENTER pour confirmer le tout et fermer cette fenêtre DOS.


Entrer dans le projet
21. Vous retrouvez à ce moment-là la fenêtre d'interface graphique avec dans le champ Project Location le dossier que vous venez de créer (Iles_Malouines dans notre exemple). En cliquant sur ce nom apparaît dans le champ Accessible Mapsets le sous-dossier PERMANENT qui a été créé. Sélectionnez-le. Le bouton grisé Enter GRASS en bas à gauche devient alors vert et actif. Cliquez sur lui pour entrer dans GRASS.


Importation de la carte dans GRASS GIS[modifier | modifier le code]

Lancer le module d'importation
22. Importer la carte GeoTiff au format de GRASS : Aller dans File -> Import raster map -> Multiple formats using GDAL. Une fenêtre r.in.gdal spécifique au module s'ouvre.


Sélectionner la carte GeoTiff
23. Sélectionner l'onglet Required (1). Cliquer sur le bouton représentant un dossier (2) et naviguer dans l'arborescence pour sélectionner la carte GeoTiff créée dans 3DEM qui se trouve dans le répertoire C:\GRASS\GIS DataBase. Entrer un nom pour la carte dans le champ Name for output raster map (3).


Importer la carte GeoTiff
24. Cliquer sur le bouton Run pour lancer l'importation qui est détaillée dans la fenêtre Output - GIS.m. Quand l'importation est achevée, fermer la fenêtre du module puis quitter GRASS.


Création du projet UTM pour la carte dans GRASS GIS[modifier | modifier le code]

Relancer GRASS
25. Ouvrir à nouveau GRASS et cliquer sur le bouton Projection values pour créer un nouveau projet suivant une projection UTM.


Créer un projet UTM
26. Entrer pour le projet (LOCATION:) un nom spécifique. Le plus pratique est de reprendre celui du projet Lat/Lon créé précédemment et d'ajouter _UTM à la fin. Appuyer sur ENTER puis sur ESC et à nouveau sur ENTER.


Confirmer la création du projet
27. Confirmer la création du projet avec ENTER.


Rassembler les informations nécessaires
28. Poursuivre en appuyant sur ENTER.


Sélectionner une projection UTM
29. Pour la projection, taper C (UTM) puis deux fois ENTER.


Description du sujet du projet
30. Donner une courte description du projet et appuyer trois fois sur ENTER.


Spécifier le système géodésique
31. Pour le système géodésique, entrer à nouveau wgs84 et appuyer sur ENTER.


Spécifier le paramètre de transformation
32. Pour les paramètres de transformation, taper 1 et appuyer sur ENTER.


Sélectionner l'hémisphère
33. Sélectionner l'hémisphère dans lequel est situé la carte par y ou n puis ENTER.


Entrer le numéro de la zone UTM
34. Entrer le numéro de la zone UTM de la carte puis appuyer sur ENTER.


Entrer les coordonnées UTM limites de la carte
35. Entrer les coordonnées métriques UTM de la carte indiquées par 3DEM au point < 6 > ou calculées au point < 9 > si la carte couvre plus d'un fuseau UTM. Appuyer sur ENTER pour changer de champ.


Spécifier la résolution de la carte
36. GRID RESOLUTION : entrer la résolution en mètres par pixel souhaitée de la carte. Pour une résolution native des SRTM3, entrer 93. Entrer 186 pour une résolution deux fois moindre et donc une carte deux fois plus petite. Confirmer vos choix avec ENTER puis ESC et à nouveau ENTER.


Récapitulation des informations
37. À la page suivante, vérifier les données récapitulées, en particulier la taille en pixels (nombre de rows et cols) de la carte, puis entrer y et ENTER pour confirmer les choix.


Confirmation de la création du projet
38. Le projet (LOCATION) est alors créé. Appuyer sur ENTER pour revenir à l'écran DOS initial puis ESC et à nouveau ENTER pour fermer cette fenêtre.


Entrer dans le projet UTM
39. Vous retrouvez alors la fenêtre de démarrage de GRASS avec dans le champ Project Location le dossier qui vient d'être créé (Iles_Malouines_UTM dans notre exemple). Cliquer dessus puis sur PERMANENT dans le champ Accessible Mapsets et enfin sur le bouton Enter GRASS pour entrer dans le logiciel.


Re-projection de la carte[modifier | modifier le code]

Re-projeter la carte
40. Dans la fenêtre de gestion de GRASS, aller dans Raster -> Develop map -> Reproject. Dans la nouvelle fenêtre du module r.proj, entrer dans le champ Name of input raster map to re-project le nom de la carte traitée précédemment au point < 23 >. Dans Location of input raster map:, indiquer le nom du projet suivant la projection Lat/Lon qui est l'endroit où se trouve la carte-source. Dans Name for output raster map, entrer le nom de la carte en ajoutant _UTM pour la différencier de la première. Quand le processus est achevé (indiqué par « r.proj complete » dans la fenêtre Output - GIS.m), fermer la fenêtre du module r.proj.


Ajouter une couche bitmap
41. Dans la fenêtre de gestion, créer une couche bitmap (bouton Add raster layer) et cliquer sur le bouton à droite de Base map: et sélectionner la carte qui vient d'être re-projetée.


Afficher la carte
42. Dans la fenêtre Map Display 1, cliquer sur le premier bouton Display active layers ce qui aura pour effet d'afficher la carte.


Module de modification de table de couleurs appliquée à une carte
43. Les couleurs étant peu agréables, vous pouvez les changer en allant dans la fenêtre principale dans Raster -> Manage map colors -> Color tables qui ouvre une fenêtre pour ce module r.colors. Aller dans l'onglet Required, cliquer sur le bouton et sélectionner votre carte.


Changer de table de couleurs
44. Sous l'onglet Colors, dérouler la liste Type of color table: et sélectionner par exemple < srtm >. Cliquer sur le bouton Run puis fermer la fenêtre de ce module.


Actualiser l'affichage de la carte
45. Pour faire apparaître les modifications, cliquer sur le deuxième bouton Redraw all layers de la fenêtre Map Display 1.


Afficher une échelle linéaire
46. Afficher une échelle linéaire en cliquant sur le bouton Scalebar and north arrow dans la fenêtre de gestion : celle-ci permettra la création de l'échelle dans la carte finale. Rafraîchir l'affichage de la carte. Sauvegarder un aperçu de cette carte avec l'échelle (celle-ci n'est pas intégrée à la carte quand on procède à une exportation avec le module r.out.png) en cliquant dans la fenêtre Map Display 1 sur le bouton représentant une disquette puis JPG -> very high resolution. Enregistrer l'image par exemple sous Vue_topo_GRASS_scale (sauvegardée par défaut dans le répertoire C:\GRASS).


Exporter un aperçu de la carte
47. Exporter la carte bitmap : aller dans File -> Export raster map -> PNG. Dans la fenêtre du module d'exportation, cliquer sur le bouton dans le champ Raster file to be converted: et sélectionner votre carte. Dans le champ Name for new PNG file, remplacer <rasterfilename> par < Vue_topo_GRASS > puis cliquer sur Run. Votre image sera stockée par défaut dans le répertoire racine du logiciel : C:\GRASS. Garder le module ouvert.


Extraction des niveaux d'altitudes[modifier | modifier le code]

Ce chapitre indique comment extraire les niveaux d'altitudes qui seront vectorisés dans Inkscape afin de créer une carte topographique vectorielle. Si vous souhaitez réaliser une carte ayant le même aspect mais bitmap, consultez la dernière section de ce chapitre.


Détermination du nombre de courbes de niveaux
1. Détermination du nombre de courbes de niveau qui seront représentées sur la carte. Pour cela, récupérer les informations altimétriques du MNT : dans la fenêtre de gestion, cliquer sur le bouton avec un grand < i > bleu à droite du nom de la carte (ou clic-droit sur la couche, puis Metadata). Dans la fenêtre < Output - GIS.m > s'affichent diverses informations concernant le MNT, en particulier ses altitudes minimale et maximale. Dans notre exemple, une île, seule l'altitude maximale nous intéresse (ici : 701 m)[6].
  • Choisir de préférence une équidistance avec un chiffre « rond » (50, 100, 200 ou 250 m, etc.). Dans notre exemple avec un relief composé de collines, une équidistance de 100 m est la plus adaptée, ce qui nécessitera huit tranches d'altitudes (0 à 100 m ; 100 à 200 m ; … ; 700 à 800 m)[7], valeur raisonnable pour représenter clairement un relief : trop peu de tranches ne permettront pas de visualiser correctement la structure du relief alors qu'un nombre supérieur à 11 tranches entraînera probablement un rapprochement excessif de leurs limites qui rendra difficile leur séparation visuelle sur la carte finale.
  • Pour une carte comportant un littoral, la première tranche d'altitude est la plus importante car c'est elle qui permettra de distinguer convenablement les plaines côtières des premières collines. Cette valeur se situe généralement vers 50 m, éventuellement 100 m si le terrain est particulièrement accidenté. Dans l'exemple ci-contre nous choisirons 50 m, les tranches suivantes étant celles de 100 m, 200 m, 300 m, etc., ce qui nous fera donc un total de neuf tranches (couleurs).


Éditer une table de couleurs
2. Ouvrir l'explorateur, aller dans C:\GRASS\etc\colors, sélectionner le fichier srtm et l'éditer avec un éditeur texte, par exemple OpenOffice.org Writer (éviter le bloc-note de Windows qui gère mal l'UTF-8). Enregistrer dès à présent ce fichier au format .txt sous un autre nom, par exemple < Noir&Blanc > pour éviter de modifier le fichier original par erreur.


Spécifier une nouvelle table
2. Supprimer tout le texte qu'il contient et coller celui ci-dessous.
-500 white
50 white
50 black
10000 black
Sauvegarder. Ce fichier est une table de couleurs qui peut être utilisée pour une carte. Telle qu'elle est présentée ici, la table spécifie que pour les altitudes de -500 m à +50 m la carte sera blanche et de 50 m à 10 000 m elle sera noire. La ligne < 50 white > sert à obtenir une transition de couleurs franche. Si elle était absente, la transition serait faite d'un dégradé de gris comme cela peut être observé en affichant une carte avec la table des couleurs srtm. La valeur < 50 > indique que cette table servira à extraire la tranche d'altitude des 50 m. Garder le fichier ouvert.


Modifier la table appliquée à la carte
3. Modifier la table colorimétrique appliquée à la carte : ouvrir à nouveau le module r.colors (Raster -> Manage map colors -> Color tables). Sous l'onglet Required, sélectionnez votre carte et sous l'onglet Colors, la table < Noir&Blanc.txt > qui vient d'être créée. Cliquer sur Run pour lancer l'opération. Dans la fenêtre Map Display 1, cliquer sur le bouton Redraw all layers pour rafraîchir l'affichage.


Exporter la première tranche d'altitude
4. Exporter (File -> Export raster map -> PNG) cette tranche d'altitude : spécifier comme nom du fichier PNG50_m > puis cliquer sur Run.


Modifier les valeurs de la table de couleurs
5. Activer à nouveau le fichier texte < Noir&Blanc > et modifier les deux valeurs < 50 > par < 100 > pour extraire cette tranche d'altitude. Sauvegarder les modifications.


Exporter la deuxième tranche d'altitude
6. Cliquer à nouveau sur le bouton Run du module r.colors pour que les modifications soient prisent en compte puis rafraîchir l'affichage de la carte. Exporter celle-ci sous le nom < 100_m .png >.


7. Répéter ces opérations pour les tranches d'altitudes suivantes. Quitter GRASS.


Gtk-dialog-info.svg

Note pour la réalisation d'une carte topographique bitmap :

Table de couleurs pour une carte topo bitmap

Au-lieu d'extraire chaque tranche d'altitude, si on spécifie pour chacune d'elles les couleurs de la convention colorimétrique, on obtient une carte ayant le même aspect que la carte finale aux couleurs bien franches, mais bitmap que l'on peut exporter telle quelle. Pour cela, éditer la table de couleurs srtm contenue dans le répertoire C:\GRASS\etc\colors et remplacer son contenu par le texte suivant (exemple pour les îles Malouines – adapter les valeurs altimétriques et les couleurs à votre carte) :

-500 172 208 165
0 172 208 165
0.1 172 208 165
50 172 208 165
50 148 191 139
100 148 191 139
100 168 198 143
200 168 198 143
200 189 204 150
300 189 204 150
300 209 215 171
400 209 215 171
400 239 235 192
500 239 235 192
500 222 214 163
600 222 214 163
600 202 185 130
700 202 185 130
700 192 154 83

Sauvegarder au format .txt sous un nom spécifique. Appliquez cette nouvelle table de couleurs à votre carte et exportez-la au format png. La couleur de la mer est ici la même que celle de la première tranche d'altitude pour corriger les imprécisions du trait de côte des SRTM[2]. Le littoral définitif sera réalisé à partir des SWBD.

Création de la carte des SWBD[modifier | modifier le code]

Vectorisation des niveaux d'altitudes[modifier | modifier le code]

Ouvrir la carte < Vue_topo_GRASS.png >
1. Dans Inkscape, ouvrir (CTL + O) la carte Vue_topo_GRASS.png : le document s'adapte automatiquement à la taille de la carte.


Créer de nouveaux calques
2. Créer de nouveaux calques, un pour chaque niveau d'altitude, sans oublier le calque < Terres > qui accueillera la carte des terres émergées (le trait de côte) issue des SWBD. Déplacer la carte de GRASS vers son calque. En haut de pile, créer aussi un calque < Légende >.


3. Importer l'image Vue_topo_GRASS_scale.jpg (celle avec l'échelle kilométrique) dans le même calque que la carte de GRASS. Redimensionner l'aperçu pour le faire coïncider avec la carte principale puis le déplacer sous celle-ci.


Dessiner un rectangle
4. Dessiner dans le calque < Légende > un rectangle vide aux contours noirs d'une épaisseur d'environ deux pixels avec le cadrage de la carte finale : il permettra de visualiser les limites de celle-ci et d'effectuer le recadrage des MNT. Verrouiller ce calque et « éteindre » le calque Vue topo GRASS.


Importer le niveau < 50 m >
5. Activer le calque 50 m et importer (CTL + I) la carte 50_m.png. L'aligner sur la page (X = 0 - Y = 0).


Spécifier les valeurs des options de vectorisation
6. Zoomer vers 140 % et aller dans Chemin -> Vectoriser le bitmap… Dans la nouvelle fenêtre, sélectionner Seuil de luminosité (la valeur du seuil n'a pas d'importance). Sous l'onglet Options, pour Supprimer les parasites, indiquer une taille de < 5 >[8] ; pour Adoucir les coins, spécifier la valeur maximale < 1,34 > ; pour Optimiser les chemins, une tolérance de < 5,00 >.


7. Cliquer sur Valider pour débuter la vectorisation de l'image.


Supprimer le remplissage et marquer le contour en rouge
8. Ouvrir l'éditeur des objets (MAJ + CTL + F) et supprimer le remplissage. Dans l'onglet Remplissage du contour, cliquer sur l'icône d'aplat et spécifier une valeur pour le rouge de < 255 > par exemple afin d'avoir un bon contraste par rapport à l'image en noir et blanc.


Spécifier une valeur de simplification
9. Ouvrir l'éditeur des préférences globales d'Inkscape (MAJ +CTL + P). Dans Divers, spécifier un seuil de simplification de < 0,0001 >[9]. Fermer cette fenêtre.


10. Observer au bas de la fenêtre le nombre de nœuds que contient le chemin et effectuer une première simplification en appuyant sur < CTL + L >. Observer le chemin : si le tracé devient distordu et prend un aspect qui n'est pas naturel, c'est que le seuil de simplification est trop important. Annuler dans ce cas la simplification, diminuer le seuil dans les préférences d'Inkscape, sélectionner à nouveau le chemin et effectuer une simplification. Appuyer une seconde fois sur < CTL + L > et vérifier le tracé du chemin : continuer la simplification si le contour reste fidèle ou annuler la dernière simplification dans le cas contraire. Une simplification optimale permet de réduire notablement le nombre de nœuds jusqu'à une valeur produisant un fichier de poids raisonnable pour l'Internet tout en préservant un chemin qui suit le plus fidèlement possible le trait de côte original. Lorsque le résultat est satisfaisant, sélectionner l'image bitmap et supprimer-la. Enregistrer le fichier SVG avec un nom de travail.
Échelle d'une carte et simplification des chemins : La résolution native d'un SRTM3 est de 93 m par pixel à l'équateur. En prenant pour standard de précision 0,25 mm quand la carte est imprimée, l'échelle native de ce type de MNT est 1:372 000e (voir l'article détaillé : Calcul de l'échelle d'une carte). Si lors de la simplification des chemins ceux-ci ne s'éloignent pas de plus d'un pixel du tracé original, la précision spatiale sera à deux pixels près (+/- 1 pixel), soit 186 m ce qui équivaut à une échelle de 1:744 000e. Il faudra donc adapter le seuil de simplification des chemins en fonction de la précision recherchée pour la carte.
Seuil de simplification trop élevé
Simplification correcte
Seuil de simplification trop élevé produisant un tracé distordu Simplification raisonnable avec un tracé fidèle


Vectoriser le niveau < 100_m.png >
11. Activez le calque < 100 m >, importez (CTL + I) l'image bitmap < 100_m.png > et alignez-la sur le document (X = 0 ; Y = 0). Procédez de la même façon pour vectoriser cette image.


Vectoriser les autres niveaux
12. Effectuer la vectorisation des autres niveaux sans oublier au préalable d'aligner les images dans le document car il n'y aura plus moyen d'aligner correctement le chemin seul par la suite. Enregistrer le document.


Cas particulier du niveau < 700 m > dans cet exemple
13. Remarque concernant le niveau < 700 m > pour l'exemple ci-contre : GRASS ayant trouvé dans le MNT une altitude maximale de 701 m, ce niveau contient très peu d'informations. Avec un seuil de suppression des parasites lors de la vectorisation réglé à < 5 >, cette opération ne capturera aucun chemin. Pour éviter cela, régler ce paramètre à < 0 > avant d'effectuer la vectorisation.


Intégration de la carte SWBD[modifier | modifier le code]

Créer un calque < Lacs >
1. Activer le calque < 700 m > et créer un calque < Lacs > à placer au-dessus. « Éteindre » tous les calques sauf < Vue topo GRASS >, < Terres > et < Légende >.


Importer la carte des SWBD
2. Activer le calque < Terres > et importer la carte SWBD créée grâce au didacticiel de création de la carte des surfaces aquatiques. Ce calque comporte normalement un groupe de deux chemins, un pour le trait de côte et un pour les lacs et rivières larges. L'aligner parfaitement au-dessus de l'aperçu de 3DEM. Augmenter le zoom vers 300 % pour vérification car cette étape est extrêmement importante pour éviter tout décalage entre la carte SWBD et les différents niveaux du relief et risquer par exemple de trouver un lac sur un flanc de coteau. Sauvegarder.


3. Dégrouper (CTL + MAJ + G) les deux chemins de la carte SWBD (trait de côte / lacs + rivières). Ne sélectionner que celui des lacs et rivières et le déplacer vers le calque < Lacs >.


Création de la carte des ombres du relief[modifier | modifier le code]

Recadrage de la carte[modifier | modifier le code]

Importer l'image des ombres
Avant de tourner et recadrer la carte, il peut être intéressant d'importer la bathymétrie et les différents chemins (rivières, frontières, etc.) s'ils sont créés et reprojetés avec GRASS. Les images sont plus faciles à importer et à aligner avant la rotation et recadrage !
1. Créer un calque < Ombres > entre les calques < 700 m > et < Lacs > et y importer l'image optimisée des ombres. L'aligner dans la page puis « éteindre » ce calque.


Importer l'aperçu de 3DEM
2. Créer un calque < Aperçu 3DEM > au-dessus du calque < Lacs > et y importer cette image (celle sous projection UTM avec la grille des coordonnées). L'aligner sur la page et vérifier son positionnement correct par rapport à la carte de GRASS en la rendant en partie transparente. Ramener son opacité à < 100% >.


Tracer une ligne droite de référence
3. Déverrouiller le calque < Légende >. Sélectionner l'outil MAJ + F6 et tracer une ligne horizontale et / ou verticale en maintenant la touche CTL enfoncée, de manière qu'elle soit proche de l'une des lignes de coordonnées. Cette(ces) ligne(s) va(vont) servir de référence lors de la rotation des calques pour mettre la carte d'aplomb (que le Nord soit vertical au centre de la carte). Verrouiller à nouveau ce calque.


Sélectionner tous les objets de la carte
4. Vérifier que tous les autres calques soient visibles et déverrouillés. Avec l'outil F1 activé, sélectionner tous les objets contenus dans la carte (CTL + ALT + A). Cliquer sur la carte pour passer en mode Rotation.


Tourner la carte
5. Cliquer sur l'une des flèches dans un coin et faire tourner la carte : la ligne de coordonnée et la ligne droite tracée précédemment doivent se confondre aux bords du cadre contenu dans le calque < Légende > (resté immobile puisque verrouillé) qui marque les limites de la carte finale.


6. Quand le résultat est satisfaisant, activer le calque < Légende >, le déverrouiller et supprimer la ligne droite qu'il contient. Modifier le positionnement et / ou les dimensions du cadre si nécessaire pour le centrer sur le sujet. Verrouiller le calque < Aperçu 3DEM > et le rendre invisible.


Redimensionner le document
7. Rendre le calque < Lacs > invisible : seuls restent visibles l'image des ombres et le cadre noir. Sélectionner ce cadre et appeler la fenêtre des propriétés du document. Cliquer sur le bouton Ajuster la page à la sélection pour redimensionner la page à la taille de ce cadre. Fermer la fenêtre de dialogue et rendre le calque < Légende > invisible.


Exporter l'image des ombres recadrée
8. Exporter l'image des ombres recadrée : appuyer sur CTL + MAJ + E, vérifier que l'option Page soit sélectionnée, entrer un nom pour cette image (par exemple Ombres_crop.png) et lancer l'exportation.


Exporter une vue des terres émergées
9. Éteindre tous les calques sauf celui < Terres > et le remplir de noir. Supprimer son contour. Exporter cette carte qui représente les terres émergées au format PNG, par exemple sous < Terres_noir.png > et qui servira à délimiter le relief ombré. Après l'exportation, fermer la fenêtre de dialogue puis supprimer à nouveau le remplissage du chemin et appliquer un contour.


10. Si le niveau d'altitude qui s'étend sur l'ensemble du MNT dépasse du cadre limite de la carte que vous vous êtes fixée (cas général pour une carte continentale), supprimez les nœuds en-dehors de ce cadre qui alourdiraient inutilement le poids du fichier final. Effectuer cette opération pour chaque tranche d'altitudes ainsi que pour les deux chemins issus des SWBD (calques < Terres > et< Lacs >).
Le chemin brut après vectorisation
Suppression des nœuds inutiles
Le chemin brut après vectorisation Suppression des nœuds inutiles


Mise en couleurs de la carte[modifier | modifier le code]

Mise en couleur du calque < Terres >
1. Remplir le chemin du calque < Terres > du premier vert de la convention colorimétrique de la Wikipédia-fr (#ACD0A5). Vérifier que le contour soit bien du bleu #0978AB et adapter son épaisseur en fonction de la carte.


Colorer les autres niveaux
2. « Allumer » le calque < 50 m >, sélectionner le chemin et le remplir du vert suivant de la convention (#94BF8B). Supprimer son contour qui surchargerait visuellement la carte. Procéder de même pour les autres niveaux.


Exporter un aperçu de la carte topographique vectorisée
3. Exporter un aperçu de la carte topographique vectorisée et colorée (option Page) qui sera utilisé pour visualiser l'effet produit par la carte du relief ombré.


Intégration des ombres du relief[modifier | modifier le code]

Préparation de la carte[modifier | modifier le code]

1. Ouvrir dans GIMP l'aperçu de la carte vectorisée qui vient d'être créé. Ouvrir en tant que calque (CTL + ALT + O) la carte optimisée et recadrée du relief ombré (Ombres_crop.png) puis l'image Terres_noir.png.


Récupérer la couleur grise d'une zone plane
2. Activer le calque des ombres (1) et sélectionner l'outil pipette (2). Cliquer sur la mer, un lac ou une zone plane (3) représentant une plaine (éteindre le calque Terres_noir.png si nécessaire) pour récupérer cette valeur de gris comme couleur de premier plan.


Sélectionner la mer
3. Avec le calque Terres_noir.png actif (1), choisir l'outil de sélection des régions par couleur (2). Décocher l'option Lissage et régler le seuil à < 0 >. Sélectionner la zone transparente correspondant à la mer.


Supprimer les informations de cette zone du calque des ombres
4. « Éteindre » le calque Terres_noir.png, activer le calque des ombres et aller dans Édition -> Effacer : cette opération a pour finalité de ne laisser de relief apparent qu'au niveau des terres émergées car les ombres, comme le reste des données issues de MNT de la SRTM, souffrent d'imprécisions le long des côtes. Désélectionner.


Envoyer la couleur grise vers un canal alpha
5. Aller dans Couleurs -> Couleur vers alpha...[10] (1). Cliquer sur le rectangle de couleur blanche (2). Dans la nouvelle fenêtre, cliquer sur le bouton à droite du champ Notation HTML: (3) puis sur la zone représentant la couleur de premier plan définie précédemment (4). Valider la sélection de cette couleur grise puis confirmer une nouvelle fois pour envoyer cette couleur vers un canal alpha : toutes les zones planes du calque des ombres, sans relief, deviennent transparentes.


Envoyer la couleur blanche vers un canal alpha
6. Appeler à nouveau l'outil Couleur vers alpha… (1) et spécifier cette fois-ci la couleur blanche (2). Valider : les blancs (= les zones éclairées) deviennent transparents et seuls restent les ombres qui sont appliquées comme avec une fusion Multiplier.
Procéder dans cet ordre : gris puis blanc vers canal alpha, qui donne de meilleurs résultats.


Modifier la transparence du calque des ombres
7. Les ombres étant trop prononcées et Inkscape ne gérant pas la transparence des images bitmap embarquées dans un fichier SVG, il est nécessaire de préparer le calque des ombres avant de l'intégrer dans la carte topographique. Modifier la transparence du calque vers < 30 % > pour que les ombres soient suffisamment visibles et rehaussent les formes du relief mais qu'elles ne gênent pas la lecture des différentes tranches d'altitudes.


Supprimer les informations de couleur de l'image
8. Quand le résultat est satisfaisant, « Éteindre » le calque de la carte topographique issue d'Inkscape puis aller dans Image -> Mode -> Niveaux de gris : la suppression des informations de couleurs fera gagner quelques kilooctets dans la carte finale. Enregistrer les ombres au format PNG (pour la transparence), par exemple sous Shaded_relief_image.png. Quitter GIMP.


Intégration des ombres dans le fichier SVG[modifier | modifier le code]

Importer la nouvelle image des ombres
9. Revenir dans Inkscape. Rendre visible le calque < Ombres >, sélectionner l'image qu'il contient et la supprimer. Importer l'image Shaded_relief_image.png semi-transparente qui vient d'être créée et l'aligner dans le document.


Embarquer l'image bitmap dans le document
10. Embarquer cette image bitmap dans le document ce qui lui permettra d'être affichée correctement dans Wikipédia : aller dans Effets -> Images -> Incorporer toutes les images. Dans la nouvelle fenêtre, cocher l'option Incorporer seulement les images sélectionnées (pour ne pas embarquer les aperçus de GRASS et de 3DEM pour le moment cachés) puis valider. Sauvegarder.


Création de la carte de la bathymétrie[modifier | modifier le code]

Finalisation de la carte[modifier | modifier le code]

Importer la carte de la bathymétrie
1. Si la bathymétrie a été créée dans un document séparé, activer le calque < Terres > et créer de nouveaux calques, un pour chaque tranche de profondeur, à placer en-dessous (tranche la plus profonde en haut de pile). Importer la carte bathymétrique créée grâce au didacticiel dédié, l'aligner sur la page, dégrouper les chemins et déplacer chaque tranche dans son calque.


Tracer les lignes des coordonnées
2. Rendre visible le calque < Légende > afin de visualiser le cadre qu'il contient. Rendre visible le calque < Aperçu 3DEM > puis créer un nouveau calque < Coordonnées > au-dessus. Avec l'outil pour tracer des droites (MAJ + F6), dessiner avec deux points des segments par-dessus la grille de l'aperçu de 3DEM. Pour les lignes courbes des latitudes, activer l'outil F2, sélectionner les deux nœuds du segment et ajouter un nouveau nœud au milieu (1). Ne sélectionner que ce dernier nœud, cliquer sur le bouton Rendre symétriques les nœuds sélectionnés (2) et le déplacer vers le haut ou le bas pour le superposer à la grille de la carte de 3DEM (3). Ajouter les valeurs numériques des coordonnées en bord de carte.


Créer une échelle des distances
3. Créer une échelle des distances : rendre visible le calque < Vue topo GRASS > et le déplacer juste en-dessous du calque < Légende >. Sélectionner la carte principale affichée et la déplacer en bas de pile pour faire apparaître l'aperçu Vue_topo_GRASS_scale.jpg (avec l'échelle kilométrique) qui était placé en-dessous. Activer le calque < Légende > et tracer des droites (MAJ + F6) pour recopier cette échelle. Ajouter aussi une équivalence en milles pour faciliter l'internationalisation. Combiner (CTL + K) tous les segments pour transformer l'échelle en un seul chemin. Ajouter les valeurs numériques correspondantes à chaque index.
Pour réaliser assez facilement l'échelle en milles, déplacer l'échelle kilométrique afin de l'aligner en bord de page (X = 0). Avec l'outil F1, sélectionner par exemple le repère des 100 km et lire dans le champ Position X la valeur de sa position en pixels.
Sachant que 1 mi = 1,609 km (valeur approchée), si le repère 100 km est placé à 200px, vous saurez qu'il faudra positionner le repère 100 mi à 200 x 1,609 = 321,8px.


Compléter la carte avec une échelle altimétrique
4. Pour finir, créer une échelle altimétrique en remplissant les différentes cases avec les couleurs utilisées dans votre carte. Sauvegarder. Penser à supprimer les calques < Vue topo GRASS > et < Aperçu 3DEM > avant d'importer la carte dans Wikipédia.


La carte est à présent prête à recevoir les données additionnelles (rivières, frontières, villes, routes, points géodésiques, etc.). Pour ces opérations, se reporter au didacticiel dédié.

Cartes topographiques thématiques[modifier | modifier le code]

Un autre emploi de la carte topographique vectorielle qui vient d'être créée et qui ne nécessite que peu de modifications concerne les cartes topographiques thématiques.

Dans les cas pour lesquels la topographie n'est pas le sujet principal mais où la détermination des niveaux d'altitudes est essentielle, une carte avec visualisation des niveaux par code de couleurs est inutilisable car une nouvelle couche colorée représentant une zone thématique, même partiellement transparente, rendrait la carte illisible. Pour réaliser ce type de carte, nous allons utiliser la flexibilité du format SVG et ne garder que le tracé des courbes de niveau en réservant les couleurs pour les zones thématiques.

Les domaines qui peuvent nécessiter des cartes topographiques thématiques sont divers : climatologie, géologie, hydrographie, répartition de la végétation, géographie humaine, etc.

Supprimer la couleur de remplissage des niveaux
1. Ouvrir la carte topographique vectorielle dans Inkscape. Sélectionner le chemin du calque < Terres >, le remplir de blanc. Pour chacun des autres niveaux, supprimer la couleur de remplissage et spécifier un contour noir. Les contours ayant par défaut une épaisseur d'un pixel, réduire cette valeur vers < 0,500 > en fonction de votre carte afin que les chemins soient visibles mais n'envahissent pas la carte.


Créer un calque pour les données thématiques
2. « Éteindre » tous les calques des niveaux d'altitudes sauf celui des terres émergées. Créer au-dessus de celui-ci un calque < Thématique >. Dupliquer le chemin des terres et le placer dans ce calque. Supprimer sa couleur de remplissage.


3. Importez la carte bitmap thématique que vous allez utiliser comme référence. Diminuer son opacité et la redimensionner pour la positionner correctement par-dessus le chemin des terres émergées.


4. Tracer les chemins délimitant les zones thématiques. Pour celles jouxtant le littoral, dupliquer le chemin < Terres >, le combiner avec celui de la zone, puis supprimer les nœuds du littoral inutiles.


Mettre en couleur les zones thématiques
5. Finaliser la carte en supprimant les contours et en remplissant de couleur les zones thématiques. Ajouter éventuellement le long de chaque courbe la valeur de l'altitude correspondante.


Notes[modifier | modifier le code]

  1. a et b Un des défauts des fichiers SRTM est que, malgré le fait que pratiquement toutes les terres émergées aient profité d'au moins deux survols, certaines zones sont restées aveugles au rayon oblique du radar en raison de la forme accidentée du relief, entraînant des trous sans informations dans la carte.
  2. a et b Un autre défaut des fichiers SRTM est leur manque de précision au niveau des côtes, en particulier en raison des vagues qui faussent les données du radar embarqué. Les fichiers SWBD fournis par la NASA sont destinés à pallier ce défaut.
  3. Demis Mapper ne fonctionne que sous Windows 95 ou supérieur (NT4.0 ou supérieur recommandé).
  4. Exemple : le fichier N48E001.hgt.zip (décompressé : N48E001.hgt) couvre la zone comprise entre les parallèles 48° N et 49° N et les méridiens 001° E et 002° E.
  5. En réalité 1 201px x 1 201px, mais la référence des SRTM étant placée au centre de chaque pixel, on « perd » un demi-pixel de chaque côté.
  6. Les MNT ne sont pas précis au mètre près. Ainsi, la valeur la plus haute trouvée peut différer de celle que vous pouvez connaître grâce à des cartes topographiques de référence. Dans l'exemple montré par la capture d'écran, GRASS a trouvé dans le MNT une altitude maximale de 701 m. En réalité, le sommet le plus élevé des îles Malouines est le mont Usborne qui culmine à 705 m.
  7. Cet exemple est un cas particulier avec son altitude maximale établie à 701 m dans le MNT, niveau qui comportera très peu d'informations.
  8. Chiffre variable suivant votre carte.
  9. Chiffre variable en fonction du nombre de nœuds sur le chemin. Effectuer des tests avec différentes valeurs pour savoir laquelle est la plus adaptée.
  10. Pour les versions plus anciennes de GIMP, aller dans Filtres -> Couleurs -> Couleur vers alpha....