Wikipédia:Atelier graphique/Didacticiels cartographiques/Didacticiel de création de carte du relief bitmap

Une page de Wikipédia, l'encyclopédie libre.
Aller à : navigation, rechercher

L'objet de ce didacticiel est de créer assez rapidement une carte bitmap de qualité avec représentation de la topographie à partir d'un modèle numérique de terrain (MNT) issu de la Shuttle Radar Topography Mission (SRTM) grâce au logiciel 3DEM [1] [2].

Bien que la carte obtenue soit une carte du type topographique, son utilisation principale au sein de Wikipédia sera différente : les couleurs des différentes tranches d'altitudes sont représentées en dégradé ce qui ne permet pas de déterminer avec précision la limite de chaque niveau. Pour réaliser une carte à vocation réellement topographique, se référer au didacticiel de création de carte topographique vectorielle.

Carte finalisée

Le type de carte présenté ici s'appliquera donc davantage aux cas pour lesquels la représentation du relief est importante mais où la détermination des niveaux d'altitude n'est pas utile. Ces cartes seront par exemple utiles pour visualiser les enjeux stratégiques d'un événement, la représentation du relief facilitant la compréhension du terrain.

Les outils[modifier | modifier le code]

  • Ordinateur avec système d'exploitation Microsoft Windows 32 bit (Win 95/98/Me/2000, XP ou Vista)[2] ;
  • 3DEM (version utilisée : 20.0) : éditeur SIG gratuit et simple d'utilisation (toujours disponible mais dont le développement a été arrêté par l'éditeur ; ne fonctionne pas en 64 bits) avec lequel sera créée la carte (données topographiques et ombrage du relief) ;
  • GIMP (version utilisée : 2.2.13)  : éditeur bitmap qui va permettre de modifier la carte (dimensions, orientation), optimiser les ombrages du relief et intégrer les données du trait de côte et contours des lacs ;
  • GRASS GIS (version utilisée : winGRASS6.3.0RC6)  : logiciel SIG libre utilisé pour ouvrir les fichiers SWBD qui sont au format propriétaire shapefile d'ESRI[3], les re-projeter suivant une projection UTM puis les exporter au format SVG. Ces fichiers contiennent le tracé des côtes corrigés[4], les lacs et cours d'eau d'une certaine importance qui complèteront la carte ;
  • Inkscape (versions utilisées : 0.45 et 0.46) : éditeur vectoriel libre grâce auquel sera créée la carte finale des SWBD.

Sources des données[modifier | modifier le code]

Pour d'autres ressources disponibles, consulter : Ressources cartographiques géoréférencées.
Ce sont des fichiers versés dans le domaine public, compressés au format .zip qui contiennent les données topographiques numérisées de la région considérée. La zone couverte par les MNT issus de la SRTM s'étend de 56° de latitude Sud à 60° de latitude Nord. Il est nécessaire de les décompresser avant de pouvoir les utiliser dans 3DEM. Il y a trois types de fichiers SRTM :
  • SRTM1 (page de téléchargement) : ce sont les données les plus précises avec une résolution d'une seconde d'arc (31 m à l'équateur) mais qui ne sont disponibles que pour les États-Unis et leurs dépendances. Chaque fichier représente un rectangle d'un degré d'arc de côté référencé suivant les coordonnées du coin inférieur gauche[5].
  • SRTM3 (page de téléchargement) : précision de trois secondes d'arc (93 m à l'équateur) qui couvrent toutes les terres émergées comprises entre les latitudes indiquées plus haut. Type de fichiers et références identiques aux SRTM1. Ce sont ces données qui seront le plus souvent utilisées car couvrant la majorité des besoins au sein de Wikipédia.
  • SRTM30 (page de téléchargement) : précision de 30 secondes d'arc (926 m à l'équateur), adaptés pour les cartes couvrant plusieurs pays ou un continent.
Chaque carte couvre une région de 50° en latitude sur 40° en longitude référencée suivant les coordonnées du coin supérieur gauche. Chacune d'elle est contenue dans un répertoire spécifique qui regroupe un ensemble de 12 fichiers. Seuls 10 d'entre eux nous sont utiles, à l'exception des fichiers *.jpg.zip et *.gif.zip qui ne sont que des images de prévisualisation. Ces 10 fichiers devront tous être téléchargés et décompressés avant d'être utilisés dans 3DEM. Dans le logiciel, sélectionner l'option GTOPO30 Tile puis dans la nouvelle fenêtre représentant la carte du monde, centrer le cadre sur la région d'intérêt et spécifier comme projection Lat/Lon. Naviguer dans l'arborescence et sélectionner le fichier .DEM.
  • NASA SRTM Water Body Data (SWBD) (page de téléchargement) : fichiers complémentaires aux SRTM comportant le tracé des côtes précis, les lacs et cours d'eau d'une certaine importance ;

Création de la carte topographique[modifier | modifier le code]

1. Télécharger les fichiers SRTM nécessaires, les décompresser.


Chargement des modèles numériques de terrain
2. Ouvrir 3DEM. Cliquer sur File -> Load Terrain Model (1). Sélectionner l'option SRTM Data (2) puis dans la nouvelle fenêtre l'ensemble des fichiers .hgt. Confirmer avec Ouvrir.


Remplissage des pixels vides
3. Le MNT comportant des pixels sans informations[6], il est nécessaire de les remplir : appuyer sur F7 et sélectionner grâce à la souris l'ensemble de la carte (1). Confirmer avec la touche ENTER. 3DEM remplit ces pixels en interpolant les valeurs des pixels adjacents (2).


Modification des couleurs
4. Application de la convention colorimétrique de la Wikipédia-fr : ouvrir Color Scale -> Modify Scale (ou appuyer sur F3). Dans la nouvelle fenêtre, indiquer pour chaque tranche d'altitude de nouvelles valeurs RVB correspondant aux couleurs de Wikipédia ; débuter avec 9 à 11 couleurs différentes en commençant à partir de l'altitude la plus basse. Pour les niveaux les plus élevés, leur donner la même couleurs que celle de la tranche d'altitude représentative la plus élevée. Faire de même pour la mer (valeurs R : 198 - V : 236 - B : 255).


5. Sauvegarder cette échelle colorimétrique en cliquant sur le bouton Save File afin de pouvoir à nouveau l'utiliser facilement pour d'autres cartes, par exemple sous le nom « Color scale WP 11 valeurs » (appel de cette échelle grâce au bouton Load File).


Modification de l'équidistance
6. Observer les deux valeurs dans la section Altitude Range : elles indiquent les valeurs altimétriques extrêmes trouvées par 3DEM dans le MNT[7]. Diviser le nombre du champ Max par le nombre de tranches de couleurs différentes. Arrondir le résultat à la valeur de l'entier immédiatement supérieur ; multiplier ce chiffre par 14 (le nombre total de tranches dans 3DEM) et entrer le résultat en cliquant sur le bouton Modify pour remplacer l'altitude maximale. Cette opération permet de placer l'altitude maximale du MNT dans la dernière tranche de couleur représentative que vous avez choisie. Les tranches supérieures d'une même couleur ne seront en fait pas utilisées[8]. Remplacer la valeur de l'altitude minimale (normalement négative si la carte comporte une côte) par 0. Valider en cliquant sur le bouton Apply. Dans la section Terrain Colors, l'intervalle entre les tranches d'altitudes (équidistance) est recalculé par 3DEM.
Exemple appliqué à la capture d'écran ci-contre :
701 m / 11 couleurs = 63,72 m par tranche d'altitude
63,72 arrondi à 64 m
64 m x 14 tranches au total = 896 m : l'altitude « 701 m » est bien située à l'intérieur de la dernière tranche d'altitude représentative (la onzième).


7. Dans la section Terrain Type, sélectionner l'option Island/Ocean si la carte comporte une côte. Valider l'ensemble des choix en cliquant sur le bouton OK : la carte s'affiche avec les nouvelles couleurs.
Tutorial raster topo map 05a.jpg
Tutorial raster topo map 05b.jpg
Activer l'option Island/Ocean La carte avec les couleurs conventionnelles de WP-fr


Modification de l'illumination
8. Modifier l'illumination de la carte : par défaut, 3DEM utilise un éclairage venant du Sud-Ouest (240° - coin inférieur gauche) qui est naturel, mais en cartographie la norme veut que l'illumination vienne du Nord-Ouest (coin supérieur gauche). Cet éclairage, impossible dans la réalité pour l'hémisphère Nord, est devenu une convention et évite en particulier l'illusion d'optique d'inversion du relief pour laquelle on a l'impression de voir des vallées comme des montagnes et inversement. Cliquer sur Color Scale -> Shaded Relief et modifier le champ Deg Azimuth pour 315. Valider.


9. Modifier la projection : Operation -> Change Projection -> Convert to UTM Projection (1). Sélectionner l'option WGS84 (2) qui est le système géodésique utilisé par les fichiers SRTM. Valider. La carte est retracée et les méridiens, auparavant parallèles, sont à présent convergents vers les pôles.
Tutorial raster topo map 07a.jpg
Tutorial raster topo map 07b.jpg
Modification de la projection La carte suivant une projection UTM


Exemple de la Grèce s'étendant sur plus d'un fuseau UTM
10. Si en validant apparaît un message indiquant que la carte est trop grande et qu'il faut d'abord la redimensionner, c'est que votre carte couvre plus d'un fuseau UTM, opération de fusion que 3DEM n'est à l'heure actuelle pas capable de traiter. Il est alors nécessaire de redimensionner la carte : appuyer F8 et sélectionner avec la souris une zone moins large sur toute la hauteur de la carte puis valider avec ENTER. Procéder à la modification de la projection comme indiqué au point 8. Cette action devra être répétée pour l'autre partie de la carte en rechargeant les MNT correspondants dans 3DEM et les opérations reprises depuis le point 3.


Vérification des altitudes max et mini de la carte
11. Appuyer sur F3 et vérifier que les valeurs des altitudes maximales et minimales de la carte sont bien celles que vous avez spécifiées plus haut.


Redimensionnement de la carte
12. Redimensionner la carte : appuyer sur F6 et déplacer le curseur jusqu'aux valeurs largeur / hauteur en pixels désirées. Valider.


Exporter un aperçu de la carte
13. Exporter un aperçu de la carte : vérifier que le quadrillage des coordonnées soit affiché (Geo Coordinates -> Lat-Lon Grid On) (1), aller dans File -> Save Map Image (2) et sélectionner le format jpeg (3), valider et indiquer un nom pour l'image. Enregistrer. Cette carte compressée au format .jpg n'est destinée qu'à servir de référence grâce aux coordonnées pour faciliter les transformations nécessaires sur la carte finale (rotation, alignement des calques, etc.).


14. Modifier le type de terrain : le tracé des côtes des MNT de la SRTM étant imprécis, ce sont les SWBD qui seront utilisés et appliqués en tant que calque par dessus la carte. Pour éviter d'avoir à corriger plus tard l'intervalle qui existera entre le tracé des côtes des MNT et celui des SWBD, appuyer sur F3 et sélectionner dans la section Terrain Type l'option Mountain/Plain : 3DEM va considérer que la carte ne contient pas de surface aquatique et appliquera pour les altitudes inférieures à celle spécifiée (0 m) la même couleur que celle de la première tranche d'altitude.
Tutorial raster topo map 12a.jpg
Tutorial raster topo map 12b.jpg
Sélectionner l'option Mountain/Plain La carte avec la mer de la couleur des plaines


Suppression des ombrages
15. Exporter la carte : enlever le quadrillage des coordonnées (Geo Coordinates -> Lat-Lon Grid Off) (1). À ce niveau, vous avez deux possibilités concernant l'ombrage du relief : soit vous optez pour la solution basique qui consiste à exporter la carte avec l'ombrage appliqué. Ceci est plus rapide mais présente le désavantage de ne pas pouvoir optimiser la représentation des structures importantes d'un relief, en particulier si celui-ci est orienté Nord-Ouest / Sud-Est, donc dans l'axe de l'éclairage général. Si vous choisissez cette solution, exportez la carte telle quelle : File -> Save Map Image et sélectionner le format bmp pour ne pas dégrader la qualité de l'affichage (la carte ne sera enregistrée au format .jpg que lorsqu'elle sera finalisée). Entrer un nom pour la carte et valider. La seconde possibilité concernant l'ombrage implique d'exporter les ombres séparément en tant que calque (en réalité trois calques) afin d'être optimisées. Dans ce cas, supprimer les infos de l'ombrage en cliquant sur Color Scale -> Shaded Relief (2) et en spécifiant dans le champ Shade Depth (%) la valeur 0 (3). Valider puis exporter cette carte sans ombrage au format .bmp (4) pour une qualité optimale.


16. Exporter les ombres du relief. Pour cette opération et l'optimisation des calques, se reporter au didacticiel d'optimisation des ombres du relief. Fermer 3DEM.

Création de la carte des SWBD[modifier | modifier le code]

Création de la carte finale[modifier | modifier le code]

Préparation de la carte SWBD[modifier | modifier le code]

Importer la carte bitmap dans celle des SWBD
1. Ouvrir dans Inkscape la carte SWBD vectorisée. Importer (CTL + I) l'aperçu de la carte DEM (celle avec les grilles et la mer de couleur bleue au format .jpg) et placer-la en-dessous.


Spécifier la dimension du document
2. Éditer les préférences du document (CTL + MAJ + D) et spécifier dans les champs Largeur et Hauteur les dimensions en pixels de la carte JPG. Aligner cette carte sur le document (X=0 ; Y=0). Ou plus simplement, sélectionner l'aperçu 3DEM et cliquer sur le bouton < Ajuster la page à la sélection >.


Redimensionner les SWBD
3. Sélectionner les deux chemins. Cliquer sur le bouton représentant un cadenas afin de forcer un redimensionnement proportionnel de la largeur et de la hauteur du document. Redimensionner les chemins en modifiant la valeur L ou H et les positionner convenablement (champs X et Y) afin qu'ils se superposent parfaitement aux contours de la carte bitmap issue de 3DEM sur l'ensemble de la carte.


Créer un fond bleu
4. Supprimer la carte bitmap. Créer un rectangle de la taille du document, sans bordure et le remplir du bleu de la convention colorimétrique (#C6ECFF) qui représentera la mer. Placer ce rectangle sous les chemins.


Supprimer le bleu des terres émergées
5. Sélectionner le chemin représentant les côtes. Le dupliquer (CTL + D). Appuyer sur la touche MAJ et sélectionner aussi le rectangle bleu. Cliquer sur Chemin -> Exclusion : les terres émergées deviennent transparentes. Enregistrer le document puis l'exporter au format .png. Fermer Inkscape.


Montage de la carte finale[modifier | modifier le code]

Ouvrir les différentes cartes
1. Ouvrir dans GIMP la carte issue de 3DEM (celle avec la mer couleur verte au format .bmp). Ouvrir respectivement en tant que calques (CTL + ALT + O) :
Les trois calques doivent normalement parfaitement se superposer.


Appliquer aux ombres une fusion « Multiplier »
2. Activer le calque des ombres et lui appliquer une fusion « Multiplier ».


Corriger la luminosité
3. Ouvrir la boîte de dialogue de réglage des niveaux (CTL + L) et déplacer le curseur central des gris vers la gauche jusqu'à une valeur d'environ < 4,00 > pour laquelle le vert des zones planes (donc sans ombres) correspond sensiblement au vert original de ces mêmes zones (effectuer la comparaison en éteignant le calque des ombres). Valider. Enregistrer la carte au format .xcf.


Importer l'aperçu de la carte de 3DEM
4. Activer le dernier calque (celui issu des SWBD). Importer en tant que calque (CTL + ALT + O) l'aperçu de la carte de 3DEM avec les grilles des coordonnées.


Recadrer la carte
5. Réduire la taille de l'affichage. Avec l'outil de sélection rectangulaire (M), recadrer la carte pour sélectionner la zone qui vous intéresse. Cliquer sur Image -> Découper l'image pour recadrer la carte suivant la sélection. Désélectionner (CTL + D).


Mesurer l'angle de rotation nécessaire
6. Augmenter le zoom vers 400 % et sélectionner l'outil Mesure (U). Pointer la croix sur l'un des parallèles au niveau d'un bord de la carte. En maintenant le bouton gauche de la souris enfoncé, faire glisser la croix vers le bord opposé de la carte et relâcher le bouton après avoir pointé l'autre extrémité du parallèle. Dans la fenêtre de dialogue qui s'est ouverte, on peut lire la valeur de l'angle qui sera utilisée lors de la rotation de la carte afin que celle-ci soit d'aplomb (parallèles horizontaux, méridien central vertical).


Effectuer la rotation
7. Lier les quatre calques. Cliquer sur Outils -> Outils de transformation –> Rotation et indiquer la valeur de l'angle déterminée précédemment. Valider.


Récupérer la couleur de la mer
8. Activer l'onglet Couleur PP/AP et cliquer sur la pipette. Cliquer sur la mer pour récupérer cette couleur comme couleur de premier plan.


Remplir les triangles de bleu
9. Activer le calque issu des SWBD. Activer l'outil de sélection des régions contiguës (W), placer le seuil à < 0 >. Sélectionner les quatre triangles blancs résultant de la rotation. Activer l'outil Pot de peinture (MAJ + G) et remplir ces quatre zones du bleu de la mer. Désélectionner.
Remarque : Les points 8 et 9 indiquent la procédure pour des îles. Si votre carte couvre une zone continentale, le plus pratique sera, au point 5, de recadrer la carte en sélectionnant une zone un peu plus grande que vos besoins puis, pour les points 8 et 9, de recadrer une nouvelle fois pour supprimer les triangles blancs résultant de la rotation.


Carte finalisée
10. « Éteindre » le calque supérieur avec les grilles. Sauvegarder le document (toujours au format .xcf). Votre carte est à présent prête à être exportée au format .jpg pour être utilisée et recevoir les informations additionnelles (villes, routes, etc.). Pour les latitudes et longitudes, utiliser le quatrième calque avec ces grilles issu de 3DEM en l'exportant au format .jpg et tracer ces lignes dans Inkscape. Pour savoir comment ajouter ces informations complémentaires, se reporter au didacticiel d'intégration des données cartographiques complémentaires.


Notes[modifier | modifier le code]

  1. 3DEM engendre des erreurs dans les altitudes au moment de re-projeter la carte en UTM ce qui rend ce logiciel inutilisable pour une carte topographique. Pour le sujet de cette page, une carte du relief qui n'est pas destinée à déterminer avec précision les altitudes, ces erreurs passent inaperçues.
  2. a et b Cette page présente la création de la carte en utilisant le logiciel 3DEM qui n'est conçu que pour les plate-formes Microsoft Windows, mais elle peut être entièrement réalisée dans GRASS GIS ou tout autre logiciel SIG. Pour cela, voir le didacticiel de création de carte topographique vectorielle qu'on adaptera en exportant une vue bitmap de la carte avec des couleurs en dégradés au-lieu d'extraire chaque niveau d'altitude séparément.
  3. L'un des manques de 3DEM est son incapacité à lire les fichiers shapefile ce qui nécessite le recours à un autre logiciel (ici GRASS GIS).
  4. Un des défauts des fichiers SRTM est leur manque de précision au niveau des côtes, en particulier en raison des vagues qui faussent les données du radar embarqué. Les fichiers SWBD fournis par la NASA sont destinés à pallier ce défaut.
  5. Exemple : le fichier N48E001.hgt.zip (décompressé : N48E001.hgt) couvre la zone comprise entre les parallèles 48° N et 49° N et les méridiens 001° E et 002° E.
  6. Un autre défaut des fichiers SRTM est que, malgré le fait que pratiquement toutes les terres émergées aient profité d'au moins deux survols, certaines zones sont restées aveugles au rayon oblique du radar en raison de la forme accidentée du relief.
  7. Les MNT ne sont pas précis au mètre près. Ainsi, la valeur la plus haute trouvée peut différer de celle que vous pouvez connaître grâce à des cartes topographiques de référence. Dans l'exemple montré par la capture d'écran, 3DEM a trouvé dans le MNT une altitude maximale de 701 m. En réalité, le sommet le plus élevé des îles Malouines est le mont Usborne qui culmine à 705 m.
  8. Cette opération n'est pas nécessaire si vous décidez d'utiliser une échelle colorimétrique à 14 valeurs.